# CVE-2022-39265: Mail settings' command parameter injection in mybb

> An admin with settings permissions can inject commands via mail parameters, leading to remote code execution and information disclosure.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2022
- **Updated:** 22 Apr 2025
- **Also known as:** BIT-mybb-2022-39265, GHSA-hxhm-rq9f-7xj7

## What is CVE-2022-39265?

CVE-2022-39265 is a high-severity command injection vulnerability in Mybb Mybb, published on 6 Oct 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

MyBB is a free and open source forum software. The _Mail Settings_ → Additional Parameters for PHP's mail() function mail_parameters setting value, in connection with the configured mail program's options and behavior, may allow access to sensitive information and Remote Code Execution (RCE). The vulnerable module requires Admin CP access with the `_Can manage settings?_` permission and may depend on configured file permissions. MyBB 1.8.31 resolves this issue with the commit `0cd318136a`. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2022-39265?

1 open source package ship an affected version, including mybb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mybb` | Bitnami | All versions | 1.8.31 |

Products: Mybb Mybb.

## How do I fix CVE-2022-39265?

Upgrade mybb to 1.8.31 or later.

## Is CVE-2022-39265 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39265 exists.

## Other vulnerabilities in Mybb Mybb

- [CVE-2011-10018](https://insights.sbomify.com/CVE-2011-10018/): myBB 1.6.4 Backdoor Arbitrary Command Execution (critical 10.0)
- [CVE-2015-2786](https://insights.sbomify.com/CVE-2015-2786/): Information disclosure in n/a (critical 10.0)
- [CVE-2011-5133](https://insights.sbomify.com/CVE-2011-5133/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2006-0218](https://insights.sbomify.com/CVE-2006-0218/): SQL injection in n/a (critical 10.0)
- [CVE-2020-22612](https://insights.sbomify.com/CVE-2020-22612/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39265 and fix it if it is affected.

What it is: CVE-2022-39265 is a high-severity command injection vulnerability in Mybb Mybb, published on 6 Oct 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39265 exists.

Affected packages and fixed versions:
- mybb (Bitnami): affected all versions; fixed in 1.8.31

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39265/ (Markdown: https://insights.sbomify.com/CVE-2022-39265/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39265
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39265
- OSV: https://osv.dev/vulnerability/CVE-2022-39265

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39265/
Summaries are generated and may contain mistakes; the official description above is the record.
