# CVE-2022-39271: Traefik HTTP/2 connections management could cause a denial of service

> Traefik reverse proxy allows attackers to cause a denial of service by hanging HTTP/2 server connections via fatal errors.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Oct 2022
- **Updated:** 23 Apr 2025
- **Also known as:** ECHO-a0fe-769b-5c5b, GHSA-c6hx-pjc3-7fqr

## What is CVE-2022-39271?

CVE-2022-39271 is a high-severity denial of service vulnerability in Traefik Traefik, published on 11 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Traefik (pronounced traffic) is a modern HTTP reverse proxy and load balancer that assists in deploying microservices. There is a potential vulnerability in Traefik managing HTTP/2 connections. A closing HTTP/2 server connection could hang forever because of a subsequent fatal error. This failure mode could be exploited to cause a denial of service. There has been a patch released in versions 2.8.8 and 2.9.0-rc5. There are currently no known workarounds.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-39271?

4 open source packages ship an affected version, including github.com/traefik/traefik/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/traefik/traefik/v2` | Go | All versions | 2.8.8 |
| `github.com/traefik/traefik/v2` | Go | All versions | 2.8.8 |
| `github.com/traefik/traefik/v2` | Go | From 2.9.0-rc1 | 2.9.0-rc5 |
| `github.com/traefik/traefik/v2` | Go | From 2.9.0-rc1 | 2.9.0-rc5 |

Products: Traefik Traefik.

## How do I fix CVE-2022-39271?

Upgrade github.com/traefik/traefik/v2 to a fixed version for your release line: 2.8.8 or 2.9.0-rc5.

## Is CVE-2022-39271 being exploited?

There is no known exploitation of CVE-2022-39271 in the wild and no public exploit code.

## Other vulnerabilities in Traefik Traefik

- [CVE-2024-45410](https://insights.sbomify.com/CVE-2024-45410/): HTTP client can remove the X-Forwarded headers in Traefik (critical 9.8)
- [CVE-2026-88877](https://insights.sbomify.com/CVE-2026-88877/): Traefik v3.7.0 Authentication Bypass via from-to-www-redirect (critical 9.3)
- [CVE-2026-85595](https://insights.sbomify.com/CVE-2026-85595/): Traefik before v2.11.55 and v3.0.0 through v3.7.10 Authentication Bypass via digestAuth (critical 9.3)
- [CVE-2026-88007](https://insights.sbomify.com/CVE-2026-88007/): Traefik HTTP/3 Backend NTLM Connection Reuse (critical 9.1)
- [CVE-2026-88009](https://insights.sbomify.com/CVE-2026-88009/): Traefik: Rootless HTTP/1 request-target routes as "/" but is forwarded verbatim, bypassing path-scoped routing, middleware guards and access logging (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39271 and fix it if it is affected.

What it is: CVE-2022-39271 is a high-severity denial of service vulnerability in Traefik Traefik, published on 11 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39271 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/traefik/traefik/v2 (Go): affected all versions; fixed in 2.8.8
- github.com/traefik/traefik/v2 (Go): affected all versions; fixed in 2.8.8
- github.com/traefik/traefik/v2 (Go): affected from 2.9.0-rc1; fixed in 2.9.0-rc5
- github.com/traefik/traefik/v2 (Go): affected from 2.9.0-rc1; fixed in 2.9.0-rc5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39271/ (Markdown: https://insights.sbomify.com/CVE-2022-39271/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39271
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39271
- OSV: https://osv.dev/vulnerability/CVE-2022-39271

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39271/
Summaries are generated and may contain mistakes; the official description above is the record.
