# CVE-2022-39273: Default OAuth Authorization Server secret in FlyteAdmin

> Attackers can impersonate Flyte Propeller and gain unauthorized access if administrators enable internal auth without overriding the default hardcoded client secret.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-67x4-qr35-qvrm, GO-2022-1043

## What is CVE-2022-39273?

CVE-2022-39273 is a medium-severity vulnerability in flyteorg flyteadmin, published on 6 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

FlyteAdmin is the control plane for the data processing platform Flyte. Users who enable the default Flyte’s authorization server without changing the default clientid hashes will be exposed to the public internet. In an effort to make enabling authentication easier for Flyte administrators, the default configuration for Flyte Admin allows access for Flyte Propeller even after turning on authentication via a hardcoded hashed password. This password is also set on the default Flyte Propeller configmap in the various Flyte Helm charts. Users who enable auth but do not override this setting in Flyte Admin’s configuration may unbeknownst to them be allowing public traffic in by way of this default password with attackers effectively impersonating propeller. This only applies to users who have not specified the ExternalAuthorizationServer setting. Usage of an external auth server automatically turns off this default configuration and are not susceptible to this vulnerability. This issue has been addressed in version 1.1.44. Users should manually set the staticClients in the selfAuthServer section of their configuration if they intend to rely on Admin’s internal auth server. Again, users who use an external auth server are automatically protected from this vulnerability.

Weakness: CWE-798 (Use of Hard-coded Credentials)

## Which versions are affected by CVE-2022-39273?

3 open source packages ship an affected version, including github.com/flyteorg/flyteadmin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/flyteorg/flyteadmin` | Go | All versions | 1.1.44 |
| `github.com/flyteorg/flyteadmin` | Go | All versions | 1.1.44 |
| `github.com/flyteorg/flyteadmin` | Go | From 1.0.0 | 1.1.44 |

Products: Flyte Flyteadmin.

## How do I fix CVE-2022-39273?

Upgrade github.com/flyteorg/flyteadmin to 1.1.44 or later.

## Is CVE-2022-39273 being exploited?

There is no known exploitation of CVE-2022-39273 in the wild and no public exploit code.

## Other vulnerabilities in flyteorg flyteadmin

- [CVE-2022-31145](https://insights.sbomify.com/CVE-2022-31145/): Insufficient AccessToken Expiration Check in FlyteAdmin (medium 6.5)
- [CVE-2023-41891](https://insights.sbomify.com/CVE-2023-41891/): FlyteAdmin SQL Injection in List Filters (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39273 and fix it if it is affected.

What it is: CVE-2022-39273 is a medium-severity vulnerability in flyteorg flyteadmin, published on 6 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39273 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/flyteorg/flyteadmin (Go): affected all versions; fixed in 1.1.44
- github.com/flyteorg/flyteadmin (Go): affected all versions; fixed in 1.1.44
- github.com/flyteorg/flyteadmin (Go): affected from 1.0.0; fixed in 1.1.44

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39273/ (Markdown: https://insights.sbomify.com/CVE-2022-39273/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39273
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39273
- OSV: https://osv.dev/vulnerability/CVE-2022-39273

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39273/
Summaries are generated and may contain mistakes; the official description above is the record.
