{"answers":{"affected":"3 open source packages ship an affected version, including dparse. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-39280 in the wild and no public exploit code.","fix":"Upgrade dparse to 0.5.2 or later.","what":"CVE-2022-39280 is a medium-severity vulnerability in pyupio dparse, published on 6 Oct 2022."},"fix_prompt":"Check this codebase for CVE-2022-39280 and fix it if it is affected.\n\nWhat it is: CVE-2022-39280 is a medium-severity vulnerability in pyupio dparse, published on 6 Oct 2022. \nExploitation: There is no known exploitation of CVE-2022-39280 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- dparse (PyPI): affected all versions; fixed in 0.5.2\n- dparse (PyPI): affected all versions; fixed in 0.5.2\n- dparse (PyPI): affected all versions; fixed in 0.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-39280/ (Markdown: https://insights.sbomify.com/CVE-2022-39280/index.md)","id":"CVE-2022-39280","markdown":"https://insights.sbomify.com/CVE-2022-39280/index.md","name":"CVE-2022-39280","record":{"aliases":["GHSA-8fg9-p83m-x5pq","PYSEC-2022-301"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"dependency_parser","vendor":"pyup"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"dparse is a parser for Python dependency files. dparse in versions before 0.5.2 contain a regular expression that is vulnerable to a Regular Expression Denial of Service. All the users parsing index server URLs with dparse are impacted by this vulnerability. A patch has been applied in version `0.5.2`, all the users are advised to upgrade to `0.5.2` as soon as possible. Users unable to upgrade should avoid passing index server URLs in the source file to be parsed.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular expression denial of service in dparse","id":"CVE-2022-39280","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":null,"year":"2022"},"n_packages":3,"n_references":4,"next":{"headline":"Remote Denial of Service via Tasks endpoint in fat_free_crm","id":"CVE-2022-39281"},"packages":[{"ecosystem":"PyPI","fixed":["0.5.2"],"introduced":["0"],"last_affected":[],"package":"dparse","purl":null,"source":"GHSA-8fg9-p83m-x5pq"},{"ecosystem":"PyPI","fixed":["0.5.2"],"introduced":["0"],"last_affected":[],"package":"dparse","purl":"pkg:pypi/dparse","source":"GHSA-8fg9-p83m-x5pq"},{"ecosystem":"PyPI","fixed":["0.5.2"],"introduced":["0"],"last_affected":[],"package":"dparse","purl":"pkg:pypi/dparse","source":"PYSEC-2022-301"}],"prev":{"headline":"Discourse-chat plugin susceptible to XSS in channel name and description","id":"CVE-2022-39279"},"products":["dparse"],"published":"2022-10-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["pyupio"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2022-39280/"}