# CVE-2022-39280: Regular expression denial of service in dparse


- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 6 Oct 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-8fg9-p83m-x5pq, PYSEC-2022-301

## What is CVE-2022-39280?

CVE-2022-39280 is a medium-severity vulnerability in pyupio dparse, published on 6 Oct 2022. 

### Official description

dparse is a parser for Python dependency files. dparse in versions before 0.5.2 contain a regular expression that is vulnerable to a Regular Expression Denial of Service. All the users parsing index server URLs with dparse are impacted by this vulnerability. A patch has been applied in version `0.5.2`, all the users are advised to upgrade to `0.5.2` as soon as possible. Users unable to upgrade should avoid passing index server URLs in the source file to be parsed.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-39280?

3 open source packages ship an affected version, including dparse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dparse` | PyPI | All versions | 0.5.2 |
| `dparse` | PyPI | All versions | 0.5.2 |
| `dparse` | PyPI | All versions | 0.5.2 |

Products: Pyup Dependency Parser.

## How do I fix CVE-2022-39280?

Upgrade dparse to 0.5.2 or later.

## Is CVE-2022-39280 being exploited?

There is no known exploitation of CVE-2022-39280 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39280 and fix it if it is affected.

What it is: CVE-2022-39280 is a medium-severity vulnerability in pyupio dparse, published on 6 Oct 2022. 
Exploitation: There is no known exploitation of CVE-2022-39280 in the wild and no public exploit code.

Affected packages and fixed versions:
- dparse (PyPI): affected all versions; fixed in 0.5.2
- dparse (PyPI): affected all versions; fixed in 0.5.2
- dparse (PyPI): affected all versions; fixed in 0.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39280/ (Markdown: https://insights.sbomify.com/CVE-2022-39280/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39280
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39280
- OSV: https://osv.dev/vulnerability/CVE-2022-39280

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39280/
Summaries are generated and may contain mistakes; the official description above is the record.
