# CVE-2022-39281: Remote Denial of Service via Tasks endpoint in fat_free_crm

> An authenticated user can cause a remote denial of service in Fat Free CRM via the Tasks endpoint, requiring an upgrade to fix.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-p75c-5x3h-cxcg

## What is CVE-2022-39281?

CVE-2022-39281 is a medium-severity denial of service vulnerability in fatfreecrm fat_free_crm, published on 8 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

fat_free_crm is a an open source, Ruby on Rails customer relationship management platform (CRM). In versions prior to 0.20.1 an authenticated user can perform a remote Denial of Service attack against Fat Free CRM via bucket access. The vulnerability has been patched in commit `c85a254` and will be available in release `0.20.1`. Users are advised to upgrade or to manually apply patch `c85a254`. There are no known workarounds for this issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-39281?

2 open source packages ship an affected version, including fat_free_crm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fat_free_crm` | RubyGems | All versions | 0.20.1 |
| `fat_free_crm` | RubyGems | All versions | 0.20.1 |

Products: Fatfreecrm Fatfreecrm.

## How do I fix CVE-2022-39281?

Upgrade fat_free_crm to 0.20.1 or later.

## Is CVE-2022-39281 being exploited?

There is no known exploitation of CVE-2022-39281 in the wild and no public exploit code.

## Other vulnerabilities in fatfreecrm fat_free_crm

- [CVE-2018-1000842](https://insights.sbomify.com/CVE-2018-1000842/): Fat Free CRM vulnerable to Cross-site Scripting (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39281 and fix it if it is affected.

What it is: CVE-2022-39281 is a medium-severity denial of service vulnerability in fatfreecrm fat_free_crm, published on 8 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39281 in the wild and no public exploit code.

Affected packages and fixed versions:
- fat_free_crm (RubyGems): affected all versions; fixed in 0.20.1
- fat_free_crm (RubyGems): affected all versions; fixed in 0.20.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39281/ (Markdown: https://insights.sbomify.com/CVE-2022-39281/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39281
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39281
- OSV: https://osv.dev/vulnerability/CVE-2022-39281

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39281/
Summaries are generated and may contain mistakes; the official description above is the record.
