{"answers":{"affected":"3 open source packages ship an affected version, including codeigniter4/framework and codeigniter. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39284 exists.","fix":"Upgrade codeigniter4/framework to 4.2.7 or later.","what":"CVE-2022-39284 is a low-severity vulnerability in CodeIgniter4, published on 6 Oct 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-39284 and fix it if it is affected.\n\nWhat it is: CVE-2022-39284 is a low-severity vulnerability in CodeIgniter4, published on 6 Oct 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39284 exists.\n\nAffected packages and fixed versions:\n- codeigniter4/framework (Packagist): affected all versions; fixed in 4.2.7\n- codeigniter4/framework (Packagist): affected all versions; fixed in 4.2.7\n- codeigniter (Bitnami): affected from 4.0.0; fixed in 4.2.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-39284/ (Markdown: https://insights.sbomify.com/CVE-2022-39284/index.md)","id":"CVE-2022-39284","markdown":"https://insights.sbomify.com/CVE-2022-39284/index.md","name":"CVE-2022-39284","record":{"aliases":["BIT-codeigniter-2022-39284","GHSA-745p-r637-7vvp"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP web framework","requires_auth":"low_privilege","summary":"CodeIgniter4 fails to apply Secure or HttpOnly flags to cookies, exposing them to scripts and allowing potential session hijacking or data theft.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"codeigniter","vendor":"codeigniter"}],"cvss":{"score":2.6,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-732","name":"Incorrect Permission Assignment for Critical Resource"},{"id":"CWE-665","name":"Improper Initialization"}],"description":"CodeIgniter is a PHP full-stack web framework. In versions prior to 4.2.7 setting `$secure` or `$httponly` value to `true` in `Config\\Cookie` is not reflected in `set_cookie()` or `Response::setCookie()`. As a result cookie values are erroneously exposed to scripts. It should be noted that this vulnerability does not affect session cookies. Users are advised to upgrade to v4.2.7 or later. Users unable to upgrade are advised to manually construct their cookies either by setting the options in code or by constructing Cookie objects. Examples of each workaround are available in the linked GHSA.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Secure or HttpOnly flag set in Config\\Cookie is not reflected in Cookies issued in Codeigniter4","id":"CVE-2022-39284","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"security_feature_bypass","year":"2022"},"n_packages":3,"n_references":6,"next":{"headline":"Stored Cross-Site Scripting Vulnerability In File Parameter in zoneminder","id":"CVE-2022-39285"},"packages":[{"ecosystem":"Bitnami","fixed":["4.2.7"],"introduced":["4.0.0"],"last_affected":[],"package":"codeigniter","purl":"pkg:bitnami/codeigniter","source":"BIT-codeigniter-2022-39284"},{"ecosystem":"Packagist","fixed":["4.2.7"],"introduced":["0"],"last_affected":[],"package":"codeigniter4/framework","purl":null,"source":"GHSA-745p-r637-7vvp"},{"ecosystem":"Packagist","fixed":["4.2.7"],"introduced":["0"],"last_affected":[],"package":"codeigniter4/framework","purl":"pkg:composer/codeigniter4/framework","source":"GHSA-745p-r637-7vvp"}],"prev":{"headline":"FreeRDP may read and display out of bounds data","id":"CVE-2022-39283"},"products":["CodeIgniter4"],"published":"2022-10-06","related":[{"cvss_score":9.8,"headline":"CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability","id":"CVE-2025-54418","kev_date_added":null,"published":"2025-07-28"},{"cvss_score":9.8,"headline":"Remote Code Execution Vulnerability in Validation Placeholders","id":"CVE-2023-32692","kev_date_added":null,"published":"2023-05-30"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40824","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40825","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40826","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40827","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40828","kev_date_added":null,"published":"2022-10-07"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["codeigniter4"]},"summary":"CodeIgniter4 fails to apply Secure or HttpOnly flags to cookies, exposing them to scripts and allowing potential session hijacking or data theft.","url":"https://insights.sbomify.com/CVE-2022-39284/"}