# CVE-2022-39284: Secure or HttpOnly flag set in Config\Cookie is not reflected in Cookies issued in Codeigniter4

> CodeIgniter4 fails to apply Secure or HttpOnly flags to cookies, exposing them to scripts and allowing potential session hijacking or data theft.

- **Severity:** Low 2.6 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Oct 2022
- **Updated:** 22 Apr 2025
- **Also known as:** BIT-codeigniter-2022-39284, GHSA-745p-r637-7vvp

## What is CVE-2022-39284?

CVE-2022-39284 is a low-severity vulnerability in CodeIgniter4, published on 6 Oct 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

CodeIgniter is a PHP full-stack web framework. In versions prior to 4.2.7 setting `$secure` or `$httponly` value to `true` in `Config\Cookie` is not reflected in `set_cookie()` or `Response::setCookie()`. As a result cookie values are erroneously exposed to scripts. It should be noted that this vulnerability does not affect session cookies. Users are advised to upgrade to v4.2.7 or later. Users unable to upgrade are advised to manually construct their cookies either by setting the options in code or by constructing Cookie objects. Examples of each workaround are available in the linked GHSA.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource), CWE-665 (Improper Initialization)

## Which versions are affected by CVE-2022-39284?

3 open source packages ship an affected version, including codeigniter4/framework and codeigniter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codeigniter4/framework` | Packagist | All versions | 4.2.7 |
| `codeigniter4/framework` | Packagist | All versions | 4.2.7 |
| `codeigniter` | Bitnami | From 4.0.0 | 4.2.7 |

Products: Codeigniter Codeigniter.

## How do I fix CVE-2022-39284?

Upgrade codeigniter4/framework to 4.2.7 or later.

## Is CVE-2022-39284 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39284 exists.

## Other vulnerabilities in CodeIgniter4

- [CVE-2025-54418](https://insights.sbomify.com/CVE-2025-54418/): CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability (critical 9.8)
- [CVE-2023-32692](https://insights.sbomify.com/CVE-2023-32692/): Remote Code Execution Vulnerability in Validation Placeholders (critical 9.8)
- [CVE-2022-40824](https://insights.sbomify.com/CVE-2022-40824/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40825](https://insights.sbomify.com/CVE-2022-40825/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40826](https://insights.sbomify.com/CVE-2022-40826/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39284 and fix it if it is affected.

What it is: CVE-2022-39284 is a low-severity vulnerability in CodeIgniter4, published on 6 Oct 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39284 exists.

Affected packages and fixed versions:
- codeigniter4/framework (Packagist): affected all versions; fixed in 4.2.7
- codeigniter4/framework (Packagist): affected all versions; fixed in 4.2.7
- codeigniter (Bitnami): affected from 4.0.0; fixed in 4.2.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39284/ (Markdown: https://insights.sbomify.com/CVE-2022-39284/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39284
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39284
- OSV: https://osv.dev/vulnerability/CVE-2022-39284

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39284/
Summaries are generated and may contain mistakes; the official description above is the record.
