{"answers":{"affected":"3 open source packages ship an affected version, including jupyter-core. It affects 3 products.","exploited":"There is no known exploitation of CVE-2022-39286 in the wild and no public exploit code.","fix":"Upgrade jupyter-core to 4.11.2 or later.","what":"CVE-2022-39286 is a high-severity vulnerability in Debian Debian Linux, published on 26 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-39286 and fix it if it is affected.\n\nWhat it is: CVE-2022-39286 is a high-severity vulnerability in Debian Debian Linux, published on 26 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-39286 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jupyter-core (PyPI): affected all versions; fixed in 4.11.2\n- jupyter-core (PyPI): affected all versions; fixed in 4.11.2\n- jupyter-core (PyPI): affected all versions; fixed in 4.11.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-39286/ (Markdown: https://insights.sbomify.com/CVE-2022-39286/index.md)","id":"CVE-2022-39286","markdown":"https://insights.sbomify.com/CVE-2022-39286/index.md","name":"CVE-2022-39286","record":{"aliases":["DEBIAN-CVE-2022-39286","DLA-3195-1","DSA-5422-1","GHSA-m678-f26j-3hrp","MGASA-2023-0062","PYSEC-2022-42974","UBUNTU-CVE-2022-39286","USN-6153-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Jupyter core library","requires_auth":"low_privilege","summary":"Jupyter Core allows arbitrary code execution as another user by running untrusted files from the current working directory.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"jupyter_core","vendor":"jupyter"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"},{"id":"CWE-427","name":"Uncontrolled Search Path Element"},{"id":"CWE-250","name":"Execution with Unnecessary Privileges"}],"description":"Jupyter Core is a package for the core common functionality of Jupyter projects. Jupyter Core prior to version 4.11.2 contains an arbitrary code execution vulnerability in `jupyter_core` that stems from `jupyter_core` executing untrusted files in CWD. This vulnerability allows one user to run code as another. Version 4.11.2 contains a patch for this issue. There are no known workarounds.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Execution with Unnecessary Privileges in JupyterApp","id":"CVE-2022-39286","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora"],"type":"privilege_escalation","year":"2022"},"n_packages":3,"n_references":7,"next":{"headline":"Plaintext transmission of CSRF tokens in tiny-csrf","id":"CVE-2022-39287"},"packages":[{"ecosystem":"PyPI","fixed":["4.11.2"],"introduced":["0"],"last_affected":[],"package":"jupyter-core","purl":null,"source":"GHSA-m678-f26j-3hrp"},{"ecosystem":"PyPI","fixed":["4.11.2"],"introduced":["0"],"last_affected":[],"package":"jupyter-core","purl":"pkg:pypi/jupyter-core","source":"GHSA-m678-f26j-3hrp"},{"ecosystem":"PyPI","fixed":["4.11.2"],"introduced":["0"],"last_affected":[],"package":"jupyter-core","purl":"pkg:pypi/jupyter-core","source":"PYSEC-2022-42974"}],"prev":{"headline":"Stored Cross-Site Scripting Vulnerability In File Parameter in zoneminder","id":"CVE-2022-39285"},"products":["jupyter_core"],"published":"2022-10-26","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["jupyter"]},"summary":"Jupyter Core allows arbitrary code execution as another user by running untrusted files from the current working directory.","url":"https://insights.sbomify.com/CVE-2022-39286/"}