# CVE-2022-39286: Execution with Unnecessary Privileges in JupyterApp

> Jupyter Core allows arbitrary code execution as another user by running untrusted files from the current working directory.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Oct 2022
- **Updated:** 23 Apr 2025
- **Also known as:** DEBIAN-CVE-2022-39286, DLA-3195-1, DSA-5422-1, GHSA-m678-f26j-3hrp, MGASA-2023-0062, PYSEC-2022-42974, UBUNTU-CVE-2022-39286, USN-6153-1

## What is CVE-2022-39286?

CVE-2022-39286 is a high-severity vulnerability in Debian Debian Linux, published on 26 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jupyter Core is a package for the core common functionality of Jupyter projects. Jupyter Core prior to version 4.11.2 contains an arbitrary code execution vulnerability in `jupyter_core` that stems from `jupyter_core` executing untrusted files in CWD. This vulnerability allows one user to run code as another. Version 4.11.2 contains a patch for this issue. There are no known workarounds.

Weakness: CWE-269 (Improper Privilege Management), CWE-427 (Uncontrolled Search Path Element), CWE-250 (Execution with Unnecessary Privileges)

## Which versions are affected by CVE-2022-39286?

3 open source packages ship an affected version, including jupyter-core. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyter-core` | PyPI | All versions | 4.11.2 |
| `jupyter-core` | PyPI | All versions | 4.11.2 |
| `jupyter-core` | PyPI | All versions | 4.11.2 |

Products: Debian Debian Linux, Fedoraproject Fedora, Jupyter Jupyter Core.

## How do I fix CVE-2022-39286?

Upgrade jupyter-core to 4.11.2 or later.

## Is CVE-2022-39286 being exploited?

There is no known exploitation of CVE-2022-39286 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39286 and fix it if it is affected.

What it is: CVE-2022-39286 is a high-severity vulnerability in Debian Debian Linux, published on 26 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39286 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyter-core (PyPI): affected all versions; fixed in 4.11.2
- jupyter-core (PyPI): affected all versions; fixed in 4.11.2
- jupyter-core (PyPI): affected all versions; fixed in 4.11.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39286/ (Markdown: https://insights.sbomify.com/CVE-2022-39286/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39286
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39286
- OSV: https://osv.dev/vulnerability/CVE-2022-39286

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39286/
Summaries are generated and may contain mistakes; the official description above is the record.
