# CVE-2022-39287: Plaintext transmission of CSRF tokens in tiny-csrf

> Attackers can intercept CSRF tokens transmitted in plaintext, potentially bypassing CSRF protections in applications using this Node.js middleware.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Oct 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-pj2c-h76w-vv6f

## What is CVE-2022-39287?

CVE-2022-39287 is a high-severity vulnerability in valexandersaulys tiny-csrf, published on 7 Oct 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

tiny-csrf is a Node.js cross site request forgery (CSRF) protection middleware. In versions prior to 1.1.0 cookies were not encrypted and thus CSRF tokens were transmitted in the clear. This issue has been addressed in commit `8eead6d` and the patch with be included in version 1.1.0. Users are advised to upgrade. There are no known workarounds for this issue.

Weakness: CWE-319 (Cleartext Transmission of Sensitive Information)

## Which versions are affected by CVE-2022-39287?

2 open source packages ship an affected version, including tiny-csrf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tiny-csrf` | npm | All versions | 1.1.0 |
| `tiny-csrf` | npm | All versions | 1.1.0 |

Products: Tiny-Csrf Project Tiny-Csrf.

## How do I fix CVE-2022-39287?

Upgrade tiny-csrf to 1.1.0 or later.

## Is CVE-2022-39287 being exploited?

There is no known exploitation of CVE-2022-39287 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39287 and fix it if it is affected.

What it is: CVE-2022-39287 is a high-severity vulnerability in valexandersaulys tiny-csrf, published on 7 Oct 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-39287 in the wild and no public exploit code.

Affected packages and fixed versions:
- tiny-csrf (npm): affected all versions; fixed in 1.1.0
- tiny-csrf (npm): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39287/ (Markdown: https://insights.sbomify.com/CVE-2022-39287/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39287
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39287
- OSV: https://osv.dev/vulnerability/CVE-2022-39287

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39287/
Summaries are generated and may contain mistakes; the official description above is the record.
