{"answers":{"affected":"2 open source packages ship an affected version, including fastify. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-39288 in the wild and no public exploit code.","fix":"Upgrade fastify to 4.8.1 or later.","what":"CVE-2022-39288 is a high-severity denial of service vulnerability in fastify, published on 10 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-39288 and fix it if it is affected.\n\nWhat it is: CVE-2022-39288 is a high-severity denial of service vulnerability in fastify, published on 10 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-39288 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fastify (npm): affected from 4.0.0; fixed in 4.8.1\n- fastify (npm): affected from 4.0.0; fixed in 4.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-39288/ (Markdown: https://insights.sbomify.com/CVE-2022-39288/index.md)","id":"CVE-2022-39288","markdown":"https://insights.sbomify.com/CVE-2022-39288/index.md","name":"CVE-2022-39288","record":{"aliases":["GHSA-455w-c45v-86rg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js web framework","requires_auth":"none","summary":"An attacker can crash a Fastify application by sending a malicious Content-Type header, requiring an upgrade to the latest version.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fastify","vendor":"fastify"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-754","name":"Improper Check for Unusual or Exceptional Conditions"}],"description":"fastify is a fast and low overhead web framework, for Node.js. Affected versions of fastify are subject to a denial of service via malicious use of the Content-Type header. An attacker can send an invalid Content-Type header that can cause the application to crash. This issue has been addressed in commit `fbb07e8d` and will be included in release version 4.8.1. Users are advised to upgrade. Users unable to upgrade may manually filter out http content with malicious Content-Type headers.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in Fastify via Content-Type header","id":"CVE-2022-39288","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Database log access in ZoneMinder","id":"CVE-2022-39289"},"packages":[{"ecosystem":"npm","fixed":["4.8.1"],"introduced":["4.0.0"],"last_affected":[],"package":"fastify","purl":null,"source":"GHSA-455w-c45v-86rg"},{"ecosystem":"npm","fixed":["4.8.1"],"introduced":["4.0.0"],"last_affected":[],"package":"fastify","purl":"pkg:npm/fastify","source":"GHSA-455w-c45v-86rg"}],"prev":{"headline":"Plaintext transmission of CSRF tokens in tiny-csrf","id":"CVE-2022-39287"},"products":["fastify"],"published":"2022-10-10","related":[{"cvss_score":8.1,"headline":"fastify vulnerable to request body replacement via an async validation result collision","id":"CVE-2026-84504","kev_date_added":null,"published":"2026-09-04"},{"cvss_score":7.5,"headline":"fastify vulnerable to authentication bypass via malformed URLs reaching encapsulated not-found handlers","id":"CVE-2026-76169","kev_date_added":null,"published":"2026-09-04"},{"cvss_score":7.5,"headline":"fastify vulnerable to header validation bypass via incomplete schema case normalization","id":"CVE-2026-84428","kev_date_added":null,"published":"2026-09-04"},{"cvss_score":7.5,"headline":"fastify vulnerable to request validation bypass via skipped boolean false schemas","id":"CVE-2026-84469","kev_date_added":null,"published":"2026-09-04"},{"cvss_score":7.5,"headline":"fastify vulnerable to Body Schema Validation Bypass via Leading Space in Content-Type Header","id":"CVE-2026-33806","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":7.5,"headline":"Fastify's Content-Type header tab character allows body validation bypass","id":"CVE-2026-25223","kev_date_added":null,"published":"2026-02-03"},{"cvss_score":7.5,"headline":"Fastify vulnerable to invalid content-type parsing, which could lead to validation bypass","id":"CVE-2025-32442","kev_date_added":null,"published":"2025-04-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["fastify"]},"summary":"An attacker can crash a Fastify application by sending a malicious Content-Type header, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/CVE-2022-39288/"}