# CVE-2022-39288: Denial of service in Fastify via Content-Type header

> An attacker can crash a Fastify application by sending a malicious Content-Type header, requiring an upgrade to the latest version.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Oct 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-455w-c45v-86rg

## What is CVE-2022-39288?

CVE-2022-39288 is a high-severity denial of service vulnerability in fastify, published on 10 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fastify is a fast and low overhead web framework, for Node.js. Affected versions of fastify are subject to a denial of service via malicious use of the Content-Type header. An attacker can send an invalid Content-Type header that can cause the application to crash. This issue has been addressed in commit `fbb07e8d` and will be included in release version 4.8.1. Users are advised to upgrade. Users unable to upgrade may manually filter out http content with malicious Content-Type headers.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions)

## Which versions are affected by CVE-2022-39288?

2 open source packages ship an affected version, including fastify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fastify` | npm | From 4.0.0 | 4.8.1 |
| `fastify` | npm | From 4.0.0 | 4.8.1 |

Products: Fastify Fastify.

## How do I fix CVE-2022-39288?

Upgrade fastify to 4.8.1 or later.

## Is CVE-2022-39288 being exploited?

There is no known exploitation of CVE-2022-39288 in the wild and no public exploit code.

## Other vulnerabilities in fastify

- [CVE-2026-84504](https://insights.sbomify.com/CVE-2026-84504/): fastify vulnerable to request body replacement via an async validation result collision (high 8.1)
- [CVE-2026-76169](https://insights.sbomify.com/CVE-2026-76169/): fastify vulnerable to authentication bypass via malformed URLs reaching encapsulated not-found handlers (high 7.5)
- [CVE-2026-84428](https://insights.sbomify.com/CVE-2026-84428/): fastify vulnerable to header validation bypass via incomplete schema case normalization (high 7.5)
- [CVE-2026-84469](https://insights.sbomify.com/CVE-2026-84469/): fastify vulnerable to request validation bypass via skipped boolean false schemas (high 7.5)
- [CVE-2026-33806](https://insights.sbomify.com/CVE-2026-33806/): fastify vulnerable to Body Schema Validation Bypass via Leading Space in Content-Type Header (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39288 and fix it if it is affected.

What it is: CVE-2022-39288 is a high-severity denial of service vulnerability in fastify, published on 10 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39288 in the wild and no public exploit code.

Affected packages and fixed versions:
- fastify (npm): affected from 4.0.0; fixed in 4.8.1
- fastify (npm): affected from 4.0.0; fixed in 4.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39288/ (Markdown: https://insights.sbomify.com/CVE-2022-39288/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39288
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39288
- OSV: https://osv.dev/vulnerability/CVE-2022-39288

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39288/
Summaries are generated and may contain mistakes; the official description above is the record.
