# CVE-2022-39294: (DoS) Denial of Service from unchecked request length in conduit-hyper

> An attacker can cause a denial of service by sending requests with excessively large Content-Length headers, leading to memory allocation failures.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Oct 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-9398-5ghf-7pr6, RUSTSEC-2022-0066

## What is CVE-2022-39294?

CVE-2022-39294 is a high-severity denial of service vulnerability in conduit-rust conduit-hyper, published on 31 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

conduit-hyper integrates a conduit application with the hyper server. Prior to version 0.4.2, `conduit-hyper` did not check any limit on a request's length before calling [`hyper::body::to_bytes`](https://docs.rs/hyper/latest/hyper/body/fn.to_bytes.html). An attacker could send a malicious request with an abnormally large `Content-Length`, which could lead to a panic if memory allocation failed for that request. In version 0.4.2, `conduit-hyper` sets an internal limit of 128 MiB per request, otherwise returning status 400 ("Bad Request"). This crate is part of the implementation of Rust's [crates.io](https://crates.io/), but that service is not affected due to its existing cloud infrastructure, which already drops such malicious requests. Even with the new limit in place, `conduit-hyper` is not recommended for production use, nor to directly serve the public Internet.

Weakness: CWE-1284 (Improper Validation of Specified Quantity in Input), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-39294?

3 open source packages ship an affected version, including conduit-hyper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `conduit-hyper` | crates.io | From 0.2.0-alpha.3 | 0.4.2 |
| `conduit-hyper` | crates.io | From 0.2.0-alpha.3 | 0.4.2 |
| `conduit-hyper` | crates.io | From 0.2.0-alpha.3 | 0.4.2 |

Products: Conduit-Hyper Project Conduit-Hyper.

## How do I fix CVE-2022-39294?

Upgrade conduit-hyper to 0.4.2 or later.

## Is CVE-2022-39294 being exploited?

There is no known exploitation of CVE-2022-39294 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39294 and fix it if it is affected.

What it is: CVE-2022-39294 is a high-severity denial of service vulnerability in conduit-rust conduit-hyper, published on 31 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39294 in the wild and no public exploit code.

Affected packages and fixed versions:
- conduit-hyper (crates.io): affected from 0.2.0-alpha.3; fixed in 0.4.2
- conduit-hyper (crates.io): affected from 0.2.0-alpha.3; fixed in 0.4.2
- conduit-hyper (crates.io): affected from 0.2.0-alpha.3; fixed in 0.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39294/ (Markdown: https://insights.sbomify.com/CVE-2022-39294/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39294
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39294
- OSV: https://osv.dev/vulnerability/CVE-2022-39294

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39294/
Summaries are generated and may contain mistakes; the official description above is the record.
