{"answers":{"affected":"2 open source packages ship an affected version, including melisplatform/melis-cms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-39297 in the wild and no public exploit code.","fix":"Upgrade melisplatform/melis-cms to 5.0.1 or later.","what":"CVE-2022-39297 is a high-severity unsafe deserialization vulnerability in melisplatform melis-cms, published on 12 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-39297 and fix it if it is affected.\n\nWhat it is: CVE-2022-39297 is a high-severity unsafe deserialization vulnerability in melisplatform melis-cms, published on 12 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-39297 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- melisplatform/melis-cms (Packagist): affected all versions; fixed in 5.0.1\n- melisplatform/melis-cms (Packagist): affected all versions; fixed in 5.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-39297/ (Markdown: https://insights.sbomify.com/CVE-2022-39297/index.md)","id":"CVE-2022-39297","markdown":"https://insights.sbomify.com/CVE-2022-39297/index.md","name":"CVE-2022-39297","record":{"aliases":["GHSA-m3m3-6gww-7gj9"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Melis CMS plugin","requires_auth":"none","summary":"Unauthenticated attackers can execute arbitrary PHP code via unsafe deserialization in MelisCms, requiring an immediate upgrade.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"meliscms","vendor":"melistechnology"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"MelisCms provides a full CMS for Melis Platform, including templating system, drag'n'drop of plugins, SEO and many administration tools. Attackers can deserialize arbitrary data on affected versions of `melisplatform/melis-cms`, and ultimately leads to the execution of arbitrary PHP code on the system. Conducting this attack does not require authentication. Users should immediately upgrade to `melisplatform/melis-cms` \u003e= 5.0.1. This issue was addressed by restricting allowed classes when deserializing user-controlled data.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Deserialization of untrusted data in MelisCms","id":"CVE-2022-39297","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"deserialization","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Deserialization of untrusted data in MelisFront","id":"CVE-2022-39298"},"packages":[{"ecosystem":"Packagist","fixed":["5.0.1"],"introduced":["0"],"last_affected":[],"package":"melisplatform/melis-cms","purl":null,"source":"GHSA-m3m3-6gww-7gj9"},{"ecosystem":"Packagist","fixed":["5.0.1"],"introduced":["0"],"last_affected":[],"package":"melisplatform/melis-cms","purl":"pkg:composer/melisplatform/melis-cms","source":"GHSA-m3m3-6gww-7gj9"}],"prev":{"headline":"Path traversal in MelisAssetManager","id":"CVE-2022-39296"},"products":["melis-cms"],"published":"2022-10-12","related":[{"cvss_score":7.7,"headline":"Deserialization of untrusted data in MelisFront","id":"CVE-2022-39298","kev_date_added":null,"published":"2022-10-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["melisplatform"]},"summary":"Unauthenticated attackers can execute arbitrary PHP code via unsafe deserialization in MelisCms, requiring an immediate upgrade.","url":"https://insights.sbomify.com/CVE-2022-39297/"}