# CVE-2022-39298: Deserialization of untrusted data in MelisFront

> Unauthenticated attackers can execute arbitrary PHP code via unsafe deserialization in MelisFront, requiring an immediate upgrade.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Oct 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-h479-2mv4-5c26

## What is CVE-2022-39298?

CVE-2022-39298 is a high-severity unsafe deserialization vulnerability in melisplatform melis-front, published on 12 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MelisFront is the engine that displays website hosted on Melis Platform. It deals with showing pages, plugins, URL rewritting, search optimization and SEO, etc. Attackers can deserialize arbitrary data on affected versions of `melisplatform/melis-front`, and ultimately leads to the execution of arbitrary PHP code on the system. Conducting this attack does not require authentication. Users should immediately upgrade to `melisplatform/melis-front` >= 5.0.1. This issue was addressed by restricting allowed classes when deserializing user-controlled data.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2022-39298?

2 open source packages ship an affected version, including melisplatform/melis-front. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `melisplatform/melis-front` | Packagist | All versions | 5.0.1 |
| `melisplatform/melis-front` | Packagist | All versions | 5.0.1 |

Products: Melistechnology Meliscms.

## How do I fix CVE-2022-39298?

Upgrade melisplatform/melis-front to 5.0.1 or later.

## Is CVE-2022-39298 being exploited?

There is no known exploitation of CVE-2022-39298 in the wild and no public exploit code.

## Other vulnerabilities in melisplatform melis-front

- [CVE-2022-39297](https://insights.sbomify.com/CVE-2022-39297/): Deserialization of untrusted data in MelisCms (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39298 and fix it if it is affected.

What it is: CVE-2022-39298 is a high-severity unsafe deserialization vulnerability in melisplatform melis-front, published on 12 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39298 in the wild and no public exploit code.

Affected packages and fixed versions:
- melisplatform/melis-front (Packagist): affected all versions; fixed in 5.0.1
- melisplatform/melis-front (Packagist): affected all versions; fixed in 5.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39298/ (Markdown: https://insights.sbomify.com/CVE-2022-39298/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39298
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39298
- OSV: https://osv.dev/vulnerability/CVE-2022-39298

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39298/
Summaries are generated and may contain mistakes; the official description above is the record.
