# CVE-2022-39306: Grafana contains Improper Input Validation

> Attackers can exploit improper input validation in Grafana invites to sign up with arbitrary credentials and gain unauthorized organization membership.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Nov 2022
- **Updated:** 28 Jan 2026
- **Also known as:** BIT-grafana-2022-39306, CLSA-2025-1751889956, GHSA-2x6g-h2hg-rq84, GO-2024-2843, MINI-32jf-c5jh-76wr, MINI-352f-443p-jq92, MINI-6jj7-q9px-fhhv, MINI-7587-qqg8-wpqc, MINI-7h85-89ph-5h2p, MINI-7rgw-mmw9-8p6p, MINI-cx9w-hhv8-p346, MINI-gjrx-qrcx-rr38, MINI-gvq4-3v92-hcx9, MINI-j9ff-47vp-3x69, MINI-q8qc-mx74-cc2w, MINI-qc56-jhw3-hvwh, MINI-qf3j-p92q-5mgx, MINI-qqw7-4q62-8qm2, MINI-w397-pv6p-p4jj, MINI-w3jj-v98p-m2vj, MINI-w4mx-mm6q-74hx, UBUNTU-CVE-2022-39306, openSUSE-SU-2024:12564-1

## What is CVE-2022-39306?

CVE-2022-39306 is a medium-severity vulnerability in Grafana Grafana, published on 9 Nov 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Grafana is an open-source platform for monitoring and observability. Versions prior to 9.2.4, or 8.5.15 on the 8.X branch, are subject to Improper Input Validation. Grafana admins can invite other members to the organization they are an admin for. When admins add members to the organization, non existing users get an email invite, existing members are added directly to the organization. When an invite link is sent, it allows users to sign up with whatever username/email address the user chooses and become a member of the organization. This introduces a vulnerability which can be used with malicious intent. This issue is patched in version 9.2.4, and has been backported to 8.5.15. There are no known workarounds.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-39306?

6 open source packages ship an affected version, including github.com/grafana/grafana and grafana. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/grafana/grafana` | Go | All versions | None |
| `github.com/grafana/grafana` | Go | From 8.0.0 | 8.5.15 |
| `github.com/grafana/grafana` | Go | From 8.0.0 | 8.5.15 |
| `github.com/grafana/grafana` | Go | From 9.0.0 | 9.2.4 |
| `github.com/grafana/grafana` | Go | From 9.0.0 | 9.2.4 |
| `grafana` | Bitnami | From 8.0.0 | 8.5.15, 9.2.4 |
| `grafana` | openSUSE:Tumbleweed | All versions | 8.5.15-2.1 |

Products: Grafana Grafana.

## How do I fix CVE-2022-39306?

Upgrade github.com/grafana/grafana to a fixed version for your release line: 8.5.15 or 9.2.4.

## Is CVE-2022-39306 being exploited?

There is no known exploitation of CVE-2022-39306 in the wild and no public exploit code.

## Other vulnerabilities in Grafana Grafana

- [CVE-2021-43798](https://insights.sbomify.com/CVE-2021-43798/): Grafana Path Traversal (high 7.5, exploited in the wild)
- [CVE-2025-41115](https://insights.sbomify.com/CVE-2025-41115/): Incorrect privilege assignment (critical 10.0)
- [CVE-2022-39328](https://insights.sbomify.com/CVE-2022-39328/): Grafana vulnerable to race condition allowing privilege escalation (critical 9.8)
- [CVE-2022-28660](https://insights.sbomify.com/CVE-2022-28660/): Auth bypass in n/a (critical 9.8)
- [CVE-2022-26148](https://insights.sbomify.com/CVE-2022-26148/): Information disclosure in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39306 and fix it if it is affected.

What it is: CVE-2022-39306 is a medium-severity vulnerability in Grafana Grafana, published on 9 Nov 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-39306 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/grafana/grafana (Go): affected all versions; no fix listed
- github.com/grafana/grafana (Go): affected from 8.0.0; fixed in 8.5.15
- github.com/grafana/grafana (Go): affected from 8.0.0; fixed in 8.5.15
- github.com/grafana/grafana (Go): affected from 9.0.0; fixed in 9.2.4
- github.com/grafana/grafana (Go): affected from 9.0.0; fixed in 9.2.4
- grafana (Bitnami): affected from 8.0.0; fixed in 8.5.15, 9.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39306/ (Markdown: https://insights.sbomify.com/CVE-2022-39306/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39306
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39306
- OSV: https://osv.dev/vulnerability/CVE-2022-39306

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39306/
Summaries are generated and may contain mistakes; the official description above is the record.
