{"answers":{"affected":"2 open source packages ship an affected version, including io.dataease:dataease-plugin-common. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39312 exists.","fix":"Upgrade io.dataease:dataease-plugin-common to 1.15.2 or later.","what":"CVE-2022-39312 is a critical unsafe deserialization vulnerability in Dataease Dataease, published on 25 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-39312 and fix it if it is affected.\n\nWhat it is: CVE-2022-39312 is a critical unsafe deserialization vulnerability in Dataease Dataease, published on 25 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39312 exists.\n\nAffected packages and fixed versions:\n- io.dataease:dataease-plugin-common (Maven): affected all versions; fixed in 1.15.2\n- io.dataease:dataease-plugin-common (Maven): affected all versions; fixed in 1.15.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-39312/ (Markdown: https://insights.sbomify.com/CVE-2022-39312/index.md)","id":"CVE-2022-39312","markdown":"https://insights.sbomify.com/CVE-2022-39312/index.md","name":"CVE-2022-39312","record":{"aliases":["GHSA-q4qq-jhjv-7rh2"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Dataease data visualization","requires_auth":"none","summary":"Attackers can execute system commands and gain server privileges by exploiting a deserialization flaw in Dataease's MySQL JDBC connection parameters.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"dataease","vendor":"dataease"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Dataease is an open source data visualization analysis tool. Dataease prior to 1.15.2 has a deserialization vulnerability. In Dataease, the Mysql data source in the data source function can customize the JDBC connection parameters and the Mysql server target to be connected. In `backend/src/main/java/io/dataease/provider/datasource/JdbcProvider.java`, the `MysqlConfiguration` class does not filter any parameters. If an attacker adds some parameters to a JDBC url and connects to a malicious mysql server, the attacker can trigger the mysql jdbc deserialization vulnerability. Through the deserialization vulnerability, the attacker can execute system commands and obtain server privileges. Version 1.15.2 contains a patch for this issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Dataease Mysql Data Source JDBC Connection Parameters Not Verified Leads to Deserialization Vulnerability","id":"CVE-2022-39312","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"dataease:dataease","products":["dataease:dataease"],"type":"deserialization","year":"2022"},"n_packages":2,"n_references":4,"next":{"headline":"Parse Server crashes when receiving file download request with invalid byte range","id":"CVE-2022-39313"},"packages":[{"ecosystem":"Maven","fixed":["1.15.2"],"introduced":["0"],"last_affected":[],"package":"io.dataease:dataease-plugin-common","purl":null,"source":"GHSA-q4qq-jhjv-7rh2"},{"ecosystem":"Maven","fixed":["1.15.2"],"introduced":["0"],"last_affected":[],"package":"io.dataease:dataease-plugin-common","purl":"pkg:maven/io.dataease/dataease-plugin-common","source":"GHSA-q4qq-jhjv-7rh2"}],"prev":{"headline":"Compromised agents may be able to execute remote code on GoCD Server","id":"CVE-2022-39311"},"products":["dataease"],"published":"2022-10-25","related":[{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2024-57707","kev_date_added":null,"published":"2025-02-07"},{"cvss_score":9.8,"headline":"DataEase's H2 datasource has a remote command execution risk","id":"CVE-2024-46997","kev_date_added":null,"published":"2024-09-23"},{"cvss_score":9.8,"headline":"DataEase data source has deserialization vulnerability","id":"CVE-2023-33963","kev_date_added":null,"published":"2023-06-01"},{"cvss_score":9.8,"headline":"SQL injection vulnerability due to the keyword blacklist for defending against SQL injection will be bypassed","id":"CVE-2023-28437","kev_date_added":null,"published":"2023-03-24"},{"cvss_score":9.8,"headline":"Dataease before 1.11.2 allows arbitrary code execution via crafter plugin","id":"CVE-2022-34113","kev_date_added":null,"published":"2022-07-22"},{"cvss_score":9.8,"headline":"Dataease v1.11.1 SQL Injection via parameter dataSourceId","id":"CVE-2022-34115","kev_date_added":null,"published":"2022-07-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["dataease"]},"summary":"Attackers can execute system commands and gain server privileges by exploiting a deserialization flaw in Dataease's MySQL JDBC connection parameters.","url":"https://insights.sbomify.com/CVE-2022-39312/"}