# CVE-2022-39313: Parse Server crashes when receiving file download request with invalid byte range

> An attacker can crash the Parse Server backend by sending a file download request with an invalid byte range, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Oct 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-parse-2022-39313, GHSA-h423-w6qv-2wj3

## What is CVE-2022-39313?

CVE-2022-39313 is a high-severity denial of service vulnerability in Parseplatform Parse-Server, published on 24 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Versions prior to 4.10.17, and prior to 5.2.8 on the 5.x branch, crash when a file download request is received with an invalid byte range, resulting in a Denial of Service. This issue has been patched in versions 4.10.17, and 5.2.8. There are no known workarounds.

Weakness: CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2022-39313?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 4.10.17 |
| `parse-server` | npm | All versions | 4.10.17 |
| `parse-server` | npm | From 5.0.0 | 5.2.8 |
| `parse-server` | npm | From 5.0.0 | 5.2.8 |
| `parse` | Bitnami | All versions | 4.10.17, 5.2.8 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2022-39313?

Upgrade parse-server to a fixed version for your release line: 4.10.17 or 5.2.8.

## Is CVE-2022-39313 being exploited?

There is no known exploitation of CVE-2022-39313 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39313 and fix it if it is affected.

What it is: CVE-2022-39313 is a high-severity denial of service vulnerability in Parseplatform Parse-Server, published on 24 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39313 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 4.10.17
- parse-server (npm): affected all versions; fixed in 4.10.17
- parse-server (npm): affected from 5.0.0; fixed in 5.2.8
- parse-server (npm): affected from 5.0.0; fixed in 5.2.8
- parse (Bitnami): affected all versions; fixed in 4.10.17, 5.2.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39313/ (Markdown: https://insights.sbomify.com/CVE-2022-39313/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39313
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39313
- OSV: https://osv.dev/vulnerability/CVE-2022-39313

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39313/
Summaries are generated and may contain mistakes; the official description above is the record.
