CVE-2022-39314 User enumeration in the code-based login and password reset forms
Attackers can enumerate valid user accounts in Kirby CMS by exploiting differential lockout behavior in code-based or debug-enabled authentication flows.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-39314?
CVE-2022-39314 is a medium-severity vulnerability in getkirby kirby, published on 24 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Kirby is a flat-file CMS. In versions prior to 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1, Kirby is subject to user enumeration due to Improper Restriction of Excessive Authentication Attempts. This vulnerability affects you only if you are using the `code` or `password-reset` auth method with the `auth.methods` option or if you have enabled the `debug` option in production. By using two or more IP addresses and multiple login attempts, valid user accounts will lock, but invalid accounts will not, leading to account enumeration. This issue has been patched in versions 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1. If you cannot update immediately, you can work around the issue by setting the `auth.methods` option to `password`, which disables the code-based login and password reset forms.
Weakness: CWE-307
Which versions are affected by CVE-2022-39314?
8 open source packages ship an affected version, including getkirby/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
getkirby/cms Packagist | From 3.5.0 | 3.5.8.2 |
getkirby/cms Packagist | From 3.5.0 | 3.5.8.2 |
getkirby/cms Packagist | From 3.6.0 | 3.6.6.2 |
getkirby/cms Packagist | From 3.6.0 | 3.6.6.2 |
getkirby/cms Packagist | From 3.7.0 | 3.7.5.1 |
getkirby/cms Packagist | From 3.7.0 | 3.7.5.1 |
2 more packages
getkirby/cms Packagist | From 3.8.0 | 3.8.1 |
getkirby/cms Packagist | From 3.8.0 | 3.8.1 |
Products include Getkirby Kirby.
How do I fix CVE-2022-39314?
Upgrade getkirby/cms to a fixed version for your release line: 3.5.8.2, 3.6.6.2, 3.7.5.1 or 3.8.1.
Is CVE-2022-39314 being exploited?
There is no known exploitation of CVE-2022-39314 in the wild and no public exploit code.
Other vulnerabilities in getkirby kirby
- CVE-2024-26483 Kirby vulnerable to unrestricted file upload of user avatar images
- CVE-2024-41964 Insufficient permission checks in the language settings in Kirby CMS
- CVE-2026-34587 Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering
- CVE-2021-29460 Cross-site scripting (XSS) from unsanitized uploaded SVG files
- CVE-2023-38489 Kirby vulnerable to Insufficient Session Expiration after a password change
Sources
Also known as GHSA-43qq-qw4x-28f8.