# CVE-2022-39314: User enumeration in the code-based login and password reset forms

> Attackers can enumerate valid user accounts in Kirby CMS by exploiting differential lockout behavior in code-based or debug-enabled authentication flows.

- **Severity:** Medium 4.8 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Oct 2022
- **Updated:** 30 Jan 2026
- **Also known as:** GHSA-43qq-qw4x-28f8

## What is CVE-2022-39314?

CVE-2022-39314 is a medium-severity vulnerability in getkirby kirby, published on 24 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Kirby is a flat-file CMS. In versions prior to 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1, Kirby is subject to user enumeration due to Improper Restriction of Excessive Authentication Attempts. This vulnerability affects you only if you are using the `code` or `password-reset` auth method with the `auth.methods` option or if you have enabled the `debug` option in production. By using two or more IP addresses and multiple login attempts, valid user accounts will lock, but invalid accounts will not, leading to account enumeration. This issue has been patched in versions 3.5.8.2, 3.6.6.2, 3.7.5.1,  and 3.8.1.  If you cannot update immediately, you can work around the issue by setting the `auth.methods` option to `password`, which disables the code-based login and password reset forms.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2022-39314?

8 open source packages ship an affected version, including getkirby/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getkirby/cms` | Packagist | From 3.5.0 | 3.5.8.2 |
| `getkirby/cms` | Packagist | From 3.5.0 | 3.5.8.2 |
| `getkirby/cms` | Packagist | From 3.6.0 | 3.6.6.2 |
| `getkirby/cms` | Packagist | From 3.6.0 | 3.6.6.2 |
| `getkirby/cms` | Packagist | From 3.7.0 | 3.7.5.1 |
| `getkirby/cms` | Packagist | From 3.7.0 | 3.7.5.1 |
| `getkirby/cms` | Packagist | From 3.8.0 | 3.8.1 |
| `getkirby/cms` | Packagist | From 3.8.0 | 3.8.1 |

Products: Getkirby Kirby.

## How do I fix CVE-2022-39314?

Upgrade getkirby/cms to a fixed version for your release line: 3.5.8.2, 3.6.6.2, 3.7.5.1 or 3.8.1.

## Is CVE-2022-39314 being exploited?

There is no known exploitation of CVE-2022-39314 in the wild and no public exploit code.

## Other vulnerabilities in getkirby kirby

- [CVE-2024-26483](https://insights.sbomify.com/CVE-2024-26483/): Kirby vulnerable to unrestricted file upload of user avatar images (high 8.8)
- [CVE-2024-41964](https://insights.sbomify.com/CVE-2024-41964/): Insufficient permission checks in the language settings in Kirby CMS (high 8.1)
- [CVE-2026-34587](https://insights.sbomify.com/CVE-2026-34587/): Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering (high 7.6)
- [CVE-2021-29460](https://insights.sbomify.com/CVE-2021-29460/): Cross-site scripting (XSS) from unsanitized uploaded SVG files (high 7.6)
- [CVE-2023-38489](https://insights.sbomify.com/CVE-2023-38489/): Kirby vulnerable to Insufficient Session Expiration after a password change (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39314 and fix it if it is affected.

What it is: CVE-2022-39314 is a medium-severity vulnerability in getkirby kirby, published on 24 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39314 in the wild and no public exploit code.

Affected packages and fixed versions:
- getkirby/cms (Packagist): affected from 3.5.0; fixed in 3.5.8.2
- getkirby/cms (Packagist): affected from 3.5.0; fixed in 3.5.8.2
- getkirby/cms (Packagist): affected from 3.6.0; fixed in 3.6.6.2
- getkirby/cms (Packagist): affected from 3.6.0; fixed in 3.6.6.2
- getkirby/cms (Packagist): affected from 3.7.0; fixed in 3.7.5.1
- getkirby/cms (Packagist): affected from 3.7.0; fixed in 3.7.5.1
- getkirby/cms (Packagist): affected from 3.8.0; fixed in 3.8.1
- getkirby/cms (Packagist): affected from 3.8.0; fixed in 3.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39314/ (Markdown: https://insights.sbomify.com/CVE-2022-39314/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39314
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39314
- OSV: https://osv.dev/vulnerability/CVE-2022-39314

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39314/
Summaries are generated and may contain mistakes; the official description above is the record.
