CVE-2022-39315 Kirby CMS vulnerable to user enumeration in the brute force protection
Attackers can enumerate valid user accounts in Kirby CMS via brute force protection timing, exposing user existence information.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-39315?
CVE-2022-39315 is a medium-severity vulnerability in getkirby kirby, published on 25 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Kirby is a Content Management System. Prior to versions 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1, a user enumeration vulnerability affects all Kirby sites with user accounts unless Kirby's API and Panel are disabled in the config. It can only be exploited for targeted attacks because the attack does not scale to brute force. The problem has been patched in Kirby 3.5.8.2, Kirby 3.6.6.2, Kirby 3.7.5.1, and Kirby 3.8.1. In all of the mentioned releases, the maintainers have rewritten the affected code so that the delay is also inserted after the brute force limit is reached.
Which versions are affected by CVE-2022-39315?
8 open source packages ship an affected version, including getkirby/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
getkirby/cms Packagist | All versions | 3.5.8.2 |
getkirby/cms Packagist | All versions | 3.5.8.2 |
getkirby/cms Packagist | From 3.6.0 | 3.6.6.2 |
getkirby/cms Packagist | From 3.6.0 | 3.6.6.2 |
getkirby/cms Packagist | From 3.7.0 | 3.7.5.1 |
getkirby/cms Packagist | From 3.7.0 | 3.7.5.1 |
2 more packages
getkirby/cms Packagist | From 3.8.0 | 3.8.1 |
getkirby/cms Packagist | From 3.8.0 | 3.8.1 |
Products include Getkirby Kirby.
How do I fix CVE-2022-39315?
Upgrade getkirby/cms to a fixed version for your release line: 3.5.8.2, 3.6.6.2, 3.7.5.1 or 3.8.1.
Is CVE-2022-39315 being exploited?
There is no known exploitation of CVE-2022-39315 in the wild and no public exploit code.
Other vulnerabilities in getkirby kirby
- CVE-2024-26483 Kirby vulnerable to unrestricted file upload of user avatar images
- CVE-2024-41964 Insufficient permission checks in the language settings in Kirby CMS
- CVE-2026-34587 Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering
- CVE-2021-29460 Cross-site scripting (XSS) from unsanitized uploaded SVG files
- CVE-2023-38489 Kirby vulnerable to Insufficient Session Expiration after a password change
Sources
Also known as GHSA-c27j-76xg-6x4f.