{"answers":{"affected":"8 open source packages ship an affected version, including getkirby/cms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-39315 in the wild and no public exploit code.","fix":"Upgrade getkirby/cms to a fixed version for your release line: 3.5.8.2, 3.6.6.2, 3.7.5.1 or 3.8.1.","what":"CVE-2022-39315 is a medium-severity vulnerability in getkirby kirby, published on 25 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-39315 and fix it if it is affected.\n\nWhat it is: CVE-2022-39315 is a medium-severity vulnerability in getkirby kirby, published on 25 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-39315 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- getkirby/cms (Packagist): affected all versions; fixed in 3.5.8.2\n- getkirby/cms (Packagist): affected all versions; fixed in 3.5.8.2\n- getkirby/cms (Packagist): affected from 3.6.0; fixed in 3.6.6.2\n- getkirby/cms (Packagist): affected from 3.6.0; fixed in 3.6.6.2\n- getkirby/cms (Packagist): affected from 3.7.0; fixed in 3.7.5.1\n- getkirby/cms (Packagist): affected from 3.7.0; fixed in 3.7.5.1\n- getkirby/cms (Packagist): affected from 3.8.0; fixed in 3.8.1\n- getkirby/cms (Packagist): affected from 3.8.0; fixed in 3.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-39315/ (Markdown: https://insights.sbomify.com/CVE-2022-39315/index.md)","id":"CVE-2022-39315","markdown":"https://insights.sbomify.com/CVE-2022-39315/index.md","name":"CVE-2022-39315","record":{"aliases":["GHSA-c27j-76xg-6x4f"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Kirby CMS","requires_auth":"none","summary":"Attackers can enumerate valid user accounts in Kirby CMS via brute force protection timing, exposing user existence information.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"kirby","vendor":"getkirby"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-209","name":"Generation of Error Message Containing Sensitive Information"},{"id":"CWE-204","name":"Observable Response Discrepancy"}],"description":"Kirby is a Content Management System. Prior to versions 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1, a user enumeration vulnerability affects all Kirby sites with user accounts unless Kirby's API and Panel are disabled in the config. It can only be exploited for targeted attacks because the attack does not scale to brute force. The problem has been patched in Kirby 3.5.8.2, Kirby 3.6.6.2, Kirby 3.7.5.1, and Kirby 3.8.1. In all of the mentioned releases, the maintainers have rewritten the affected code so that the delay is also inserted after the brute force limit is reached.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Kirby CMS vulnerable to user enumeration in the brute force protection","id":"CVE-2022-39315","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"information_disclosure","year":"2022"},"n_packages":8,"n_references":5,"next":{"headline":"Out of bound read in FreeRDP","id":"CVE-2022-39316"},"packages":[{"ecosystem":"Packagist","fixed":["3.5.8.2"],"introduced":["0"],"last_affected":[],"package":"getkirby/cms","purl":null,"source":"GHSA-c27j-76xg-6x4f"},{"ecosystem":"Packagist","fixed":["3.5.8.2"],"introduced":["0"],"last_affected":[],"package":"getkirby/cms","purl":"pkg:composer/getkirby/cms","source":"GHSA-c27j-76xg-6x4f"},{"ecosystem":"Packagist","fixed":["3.6.6.2"],"introduced":["3.6.0"],"last_affected":[],"package":"getkirby/cms","purl":null,"source":"GHSA-c27j-76xg-6x4f"},{"ecosystem":"Packagist","fixed":["3.6.6.2"],"introduced":["3.6.0"],"last_affected":[],"package":"getkirby/cms","purl":"pkg:composer/getkirby/cms","source":"GHSA-c27j-76xg-6x4f"},{"ecosystem":"Packagist","fixed":["3.7.5.1"],"introduced":["3.7.0"],"last_affected":[],"package":"getkirby/cms","purl":null,"source":"GHSA-c27j-76xg-6x4f"},{"ecosystem":"Packagist","fixed":["3.7.5.1"],"introduced":["3.7.0"],"last_affected":[],"package":"getkirby/cms","purl":"pkg:composer/getkirby/cms","source":"GHSA-c27j-76xg-6x4f"},{"ecosystem":"Packagist","fixed":["3.8.1"],"introduced":["3.8.0"],"last_affected":[],"package":"getkirby/cms","purl":null,"source":"GHSA-c27j-76xg-6x4f"},{"ecosystem":"Packagist","fixed":["3.8.1"],"introduced":["3.8.0"],"last_affected":[],"package":"getkirby/cms","purl":"pkg:composer/getkirby/cms","source":"GHSA-c27j-76xg-6x4f"}],"prev":{"headline":"User enumeration in the code-based login and password reset forms","id":"CVE-2022-39314"},"products":["kirby"],"published":"2022-10-25","related":[{"cvss_score":8.8,"headline":"Kirby vulnerable to unrestricted file upload of user avatar images","id":"CVE-2024-26483","kev_date_added":null,"published":"2024-02-22"},{"cvss_score":8.1,"headline":"Insufficient permission checks in the language settings in Kirby CMS","id":"CVE-2024-41964","kev_date_added":null,"published":"2024-08-29"},{"cvss_score":7.6,"headline":"Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering","id":"CVE-2026-34587","kev_date_added":null,"published":"2026-04-24"},{"cvss_score":7.6,"headline":"Cross-site scripting (XSS) from unsanitized uploaded SVG files","id":"CVE-2021-29460","kev_date_added":null,"published":"2021-04-27"},{"cvss_score":7.3,"headline":"Kirby vulnerable to Insufficient Session Expiration after a password change","id":"CVE-2023-38489","kev_date_added":null,"published":"2023-07-27"},{"cvss_score":7.3,"headline":"Cross-site scripting (XSS) from writer field content in the site frontend","id":"CVE-2021-41252","kev_date_added":null,"published":"2021-11-16"},{"cvss_score":7.3,"headline":"Cross-site scripting (XSS) from image block content in the site frontend","id":"CVE-2021-41258","kev_date_added":null,"published":"2021-11-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["getkirby"]},"summary":"Attackers can enumerate valid user accounts in Kirby CMS via brute force protection timing, exposing user existence information.","url":"https://insights.sbomify.com/CVE-2022-39315/"}