CVE-2022-39322 @keystone-6/core vulnerable to field-level access-control bypass for multiselect field

Critical 9.1 Published Updated

Attackers can bypass field-level access controls on multiselect fields in Keystone 6, potentially reading or modifying restricted data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-39322?

CVE-2022-39322 is a critical missing authorization vulnerability in keystonejs keystone, published on 25 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

@keystone-6/core is a core package for Keystone 6, a content management system for Node.js. Starting with version 2.2.0 and prior to version 2.3.1, users who expected their `multiselect` fields to use the field-level access control - if configured - are vulnerable to their field-level access control not being used. List-level access control is not affected. Field-level access control for fields other than `multiselect` are not affected. Version 2.3.1 contains a fix for this issue. As a workaround, stop using the `multiselect` field.

Weakness: CWE-863, CWE-285

Which versions are affected by CVE-2022-39322?

2 open source packages ship an affected version, including @keystone-6/core. It affects 1 product.

PackageAffectedFixed in
@keystone-6/core npmFrom 2.2.02.3.1
@keystone-6/core npmFrom 2.2.02.3.1

Products include Keystonejs Keystone.

How do I fix CVE-2022-39322?

Upgrade @keystone-6/core to 2.3.1 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2022-39322 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39322 exists.

Sources

Also known as GHSA-6mhr-52mv-6v6f.

Is CVE-2022-39322 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free