{"answers":{"affected":"2 open source packages ship an affected version, including @keystone-6/core. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39322 exists.","fix":"Upgrade @keystone-6/core to 2.3.1 or later.","what":"CVE-2022-39322 is a critical missing authorization vulnerability in keystonejs keystone, published on 25 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-39322 and fix it if it is affected.\n\nWhat it is: CVE-2022-39322 is a critical missing authorization vulnerability in keystonejs keystone, published on 25 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39322 exists.\n\nAffected packages and fixed versions:\n- @keystone-6/core (npm): affected from 2.2.0; fixed in 2.3.1\n- @keystone-6/core (npm): affected from 2.2.0; fixed in 2.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-39322/ (Markdown: https://insights.sbomify.com/CVE-2022-39322/index.md)","id":"CVE-2022-39322","markdown":"https://insights.sbomify.com/CVE-2022-39322/index.md","name":"CVE-2022-39322","record":{"aliases":["GHSA-6mhr-52mv-6v6f"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js CMS framework","requires_auth":"none","summary":"Attackers can bypass field-level access controls on multiselect fields in Keystone 6, potentially reading or modifying restricted data.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"keystone","vendor":"keystonejs"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-285","name":"Improper Authorization"}],"description":"@keystone-6/core is a core package for Keystone 6, a content management system for Node.js. Starting with version 2.2.0 and prior to version 2.3.1, users who expected their `multiselect` fields to use the field-level access control - if configured - are vulnerable to their field-level access control not being used. List-level access control is not affected. Field-level access control for fields other than `multiselect` are not affected. Version 2.3.1 contains a fix for this issue. As a workaround, stop using the `multiselect` field.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"@keystone-6/core vulnerable to field-level access-control bypass for multiselect field","id":"CVE-2022-39322","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"missing_authorization","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"SQL Injection on REST API in GLPI","id":"CVE-2022-39323"},"packages":[{"ecosystem":"npm","fixed":["2.3.1"],"introduced":["2.2.0"],"last_affected":[],"package":"@keystone-6/core","purl":null,"source":"GHSA-6mhr-52mv-6v6f"},{"ecosystem":"npm","fixed":["2.3.1"],"introduced":["2.2.0"],"last_affected":[],"package":"@keystone-6/core","purl":"pkg:npm/%40keystone-6/core","source":"GHSA-6mhr-52mv-6v6f"}],"prev":{"headline":"GitHub Actions Runner vulnerable to Docker Command Escaping","id":"CVE-2022-39321"},"products":["keystone"],"published":"2022-10-25","related":[{"cvss_score":9.8,"headline":"NODE_ENV in Keystone defaults to development with esbuild","id":"CVE-2022-39382","kev_date_added":null,"published":"2022-11-03"},{"cvss_score":9.8,"headline":"File upload in n/a","id":"CVE-2022-29354","kev_date_added":null,"published":"2022-05-16"},{"cvss_score":8.8,"headline":"Cross-Site Request Forgery (CSRF) in keystone","id":"CVE-2017-16570","kev_date_added":null,"published":"2017-11-06"},{"cvss_score":8.8,"headline":"Keystone is vulnerable to CSV injection","id":"CVE-2017-15879","kev_date_added":null,"published":"2017-10-24"},{"cvss_score":7.5,"headline":"Authentication Weakness in keystone","id":"CVE-2015-9240","kev_date_added":null,"published":"2018-05-29"},{"cvss_score":7.1,"headline":"Cross-site Scripting (XSS) - Reflected in keystonejs/keystone","id":"CVE-2022-0087","kev_date_added":null,"published":"2022-01-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["keystonejs"]},"summary":"Attackers can bypass field-level access controls on multiselect fields in Keystone 6, potentially reading or modifying restricted data.","url":"https://insights.sbomify.com/CVE-2022-39322/"}