# CVE-2022-39327: Improper Control of Generation of Code ('Code Injection') in Azure CLI

> Attackers can execute arbitrary code on Windows machines via Azure CLI if external input contains specific symbols, requiring an upgrade to mitigate.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Oct 2022
- **Updated:** 22 Apr 2025
- **Also known as:** BIT-azure-cli-2022-39327, GHSA-47xc-9rr2-q7p4, PYSEC-2022-43177, UBUNTU-CVE-2022-39327

## What is CVE-2022-39327?

CVE-2022-39327 is a high-severity code injection vulnerability in azure-cli, published on 25 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Azure CLI is the command-line interface for Microsoft Azure. In versions previous to 2.40.0, Azure CLI contains a vulnerability for potential code injection. Critical scenarios are where a hosting machine runs an Azure CLI command where parameter values have been provided by an external source. The vulnerability is only applicable when the Azure CLI command is run on a Windows machine and with any version of PowerShell and when the parameter value contains the `&` or `|` symbols. If any of these prerequisites are not met, this vulnerability is not applicable. Users should upgrade to version 2.40.0 or greater to receive a a mitigation for the vulnerability.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2022-39327?

4 open source packages ship an affected version, including azure-cli. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `azure-cli` | Bitnami | All versions | 2.40.0 |
| `azure-cli` | PyPI | All versions | 2.40.0 |
| `azure-cli` | PyPI | All versions | 2.40.0 |
| `azure-cli` | PyPI | All versions | 2.40.0 |

Products: Microsoft Azure Command-Line Interface.

## How do I fix CVE-2022-39327?

Upgrade azure-cli to 2.40.0 or later.

## Is CVE-2022-39327 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39327 exists.

## Other vulnerabilities in azure-cli

- [CVE-2024-43591](https://insights.sbomify.com/CVE-2024-43591/): Azure Command Line Integration (CLI) Elevation of Privilege Vulnerability (high 8.7)
- [CVE-2023-36052](https://insights.sbomify.com/CVE-2023-36052/): Azure CLI REST Command Information Disclosure Vulnerability (high 8.6)
- [CVE-2025-24049](https://insights.sbomify.com/CVE-2025-24049/): Azure Command Line Integration (CLI) Elevation of Privilege Vulnerability (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39327 and fix it if it is affected.

What it is: CVE-2022-39327 is a high-severity code injection vulnerability in azure-cli, published on 25 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39327 exists.

Affected packages and fixed versions:
- azure-cli (Bitnami): affected all versions; fixed in 2.40.0
- azure-cli (PyPI): affected all versions; fixed in 2.40.0
- azure-cli (PyPI): affected all versions; fixed in 2.40.0
- azure-cli (PyPI): affected all versions; fixed in 2.40.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39327/ (Markdown: https://insights.sbomify.com/CVE-2022-39327/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39327
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39327
- OSV: https://osv.dev/vulnerability/CVE-2022-39327

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39327/
Summaries are generated and may contain mistakes; the official description above is the record.
