# CVE-2022-39328: Grafana vulnerable to race condition allowing privilege escalation

> An unauthenticated attacker can exploit a race condition in Grafana to access administrative endpoints and escalate privileges.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Nov 2022
- **Updated:** 28 Jan 2026
- **Also known as:** BIT-grafana-2022-39328, GHSA-vqc4-mpj8-jxch, GO-2024-2856, MINI-49rw-pc5x-7fv7, MINI-4j3c-q7c3-3m6j, MINI-6gjm-gc8q-r7v8, MINI-6xhf-4j62-p6v2, MINI-88g6-ghcg-fhhg, MINI-94j8-2f7r-hwxc, MINI-99jp-hg8c-q2rr, MINI-crrq-4w38-6h4v, MINI-g7c5-q69h-phjp, MINI-hq99-rx7j-cf8c, MINI-hqj2-4j4r-5g3h, MINI-m8h9-8rjp-j6q5, MINI-q6wm-83g3-j7ww, MINI-rrw3-72vc-985x, MINI-vvmh-q6v9-wm48, MINI-xg5p-5xrx-jcg3, MINI-xrfx-9w4j-w6gm, UBUNTU-CVE-2022-39328

## What is CVE-2022-39328?

CVE-2022-39328 is a critical vulnerability in Grafana Grafana, published on 8 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Grafana is an open-source platform for monitoring and observability. Versions starting with 9.2.0 and less than 9.2.4 contain a race condition in the authentication middlewares logic which may allow an unauthenticated user to query an administration endpoint under heavy load. This issue is patched in 9.2.4. There are no known workarounds.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2022-39328?

4 open source packages ship an affected version, including github.com/grafana/grafana and grafana. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/grafana/grafana` | Go | All versions | None |
| `github.com/grafana/grafana` | Go | From 9.2.0 | 9.2.4 |
| `github.com/grafana/grafana` | Go | From 9.2.0 | 9.2.4 |
| `grafana` | Bitnami | From 9.2.0 | 9.2.4 |

Products: Grafana Grafana.

## How do I fix CVE-2022-39328?

Upgrade github.com/grafana/grafana to 9.2.4 or later.

## Is CVE-2022-39328 being exploited?

There is no known exploitation of CVE-2022-39328 in the wild and no public exploit code.

## Other vulnerabilities in Grafana Grafana

- [CVE-2021-43798](https://insights.sbomify.com/CVE-2021-43798/): Grafana Path Traversal (high 7.5, exploited in the wild)
- [CVE-2025-41115](https://insights.sbomify.com/CVE-2025-41115/): Incorrect privilege assignment (critical 10.0)
- [CVE-2022-28660](https://insights.sbomify.com/CVE-2022-28660/): Auth bypass in n/a (critical 9.8)
- [CVE-2022-26148](https://insights.sbomify.com/CVE-2022-26148/): Information disclosure in n/a (critical 9.8)
- [CVE-2018-15727](https://insights.sbomify.com/CVE-2018-15727/): Grafana Authentication Bypass (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39328 and fix it if it is affected.

What it is: CVE-2022-39328 is a critical vulnerability in Grafana Grafana, published on 8 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39328 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/grafana/grafana (Go): affected all versions; no fix listed
- github.com/grafana/grafana (Go): affected from 9.2.0; fixed in 9.2.4
- github.com/grafana/grafana (Go): affected from 9.2.0; fixed in 9.2.4
- grafana (Bitnami): affected from 9.2.0; fixed in 9.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39328/ (Markdown: https://insights.sbomify.com/CVE-2022-39328/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39328
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39328
- OSV: https://osv.dev/vulnerability/CVE-2022-39328

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39328/
Summaries are generated and may contain mistakes; the official description above is the record.
