# CVE-2022-39335: Synapse does not apply enough checks to servers requesting auth events of events in a room

> Remote servers can improperly access authorization events in a room due to insufficient checks, potentially exposing sensitive data.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 May 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-45cj-f97f-ggwv, PYSEC-2023-65, UBUNTU-CVE-2022-39335

## What is CVE-2022-39335?

CVE-2022-39335 is a medium-severity missing authorization vulnerability in matrix-org synapse, published on 26 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Synapse is an open-source Matrix homeserver written and maintained by the Matrix.org Foundation. The Matrix Federation API allows remote homeservers to request the authorization events in a room. This is necessary so that a homeserver receiving some events can validate that those events are legitimate and permitted in their room. However, in versions of Synapse up to and including 1.68.0, a Synapse homeserver answering a query for authorization events does not sufficiently check that the requesting server should be able to access them. The issue was patched in Synapse 1.69.0. Homeserver administrators are advised to upgrade.

Weakness: CWE-862 (Missing Authorization), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-39335?

3 open source packages ship an affected version, including matrix-synapse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.69.0 |
| `matrix-synapse` | PyPI | All versions | 1.69.0 |
| `matrix-synapse` | PyPI | All versions | 1.69.0 |

Products: Matrix Synapse.

## How do I fix CVE-2022-39335?

Upgrade matrix-synapse to 1.69.0 or later.

## Is CVE-2022-39335 being exploited?

There is no known exploitation of CVE-2022-39335 in the wild and no public exploit code.

## Other vulnerabilities in matrix-org synapse

- [CVE-2019-18835](https://insights.sbomify.com/CVE-2019-18835/): Improper Verification of Cryptographic Signature in matrix-synapse (critical 9.8)
- [CVE-2024-52815](https://insights.sbomify.com/CVE-2024-52815/): Synapse allows a a malformed invite to break the invitee's `/sync` (high 8.7)
- [CVE-2024-52805](https://insights.sbomify.com/CVE-2024-52805/): Synapse allows unsupported content types to lead to memory exhaustion (high 8.2)
- [CVE-2024-53863](https://insights.sbomify.com/CVE-2024-53863/): Synapse can be forced to thumbnail unexpected file formats, invoking external, potentially untrustworthy decoders (high 8.2)
- [CVE-2024-37302](https://insights.sbomify.com/CVE-2024-37302/): Synapse denial of service through media disk space consumption (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39335 and fix it if it is affected.

What it is: CVE-2022-39335 is a medium-severity missing authorization vulnerability in matrix-org synapse, published on 26 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39335 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.69.0
- matrix-synapse (PyPI): affected all versions; fixed in 1.69.0
- matrix-synapse (PyPI): affected all versions; fixed in 1.69.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39335/ (Markdown: https://insights.sbomify.com/CVE-2022-39335/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39335
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39335
- OSV: https://osv.dev/vulnerability/CVE-2022-39335

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39335/
Summaries are generated and may contain mistakes; the official description above is the record.
