CVE-2022-39340 OpenFGA Information Disclosure

Medium 5.3 Published Updated

Attackers can access sensitive object data via the streamed-list-objects endpoint without valid authorization headers.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-39340?

CVE-2022-39340 is a medium-severity missing authorization vulnerability in openfga, published on 25 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

OpenFGA is an authorization/permission engine. Prior to version 0.2.4, the `streamed-list-objects` endpoint was not validating the authorization header, resulting in disclosure of objects in the store. Users `openfga/openfga` versions 0.2.3 and prior who are exposing the OpenFGA service to the internet are vulnerable. Version 0.2.4 contains a patch for this issue.

Weakness: CWE-862, CWE-285

Which versions are affected by CVE-2022-39340?

3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 1 product.

PackageAffectedFixed in
github.com/openfga/openfga GoAll versions0.2.4
github.com/openfga/openfga GoAll versions0.2.4
github.com/openfga/openfga GoAll versions0.2.4

Products include Openfga Openfga.

How do I fix CVE-2022-39340?

Upgrade github.com/openfga/openfga to 0.2.4 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2022-39340 being exploited?

There is no known exploitation of CVE-2022-39340 in the wild and no public exploit code.

Sources

Also known as GHSA-95x7-mh78-7w2r, GO-2022-1079.

Is CVE-2022-39340 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free