# CVE-2022-39341: OpenFGA Authorization Bypass

> Attackers can bypass authorization checks in OpenFGA if wildcard relations are used in the model, requiring a patch to secure access controls.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Oct 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-vj4m-83m8-xpw5, GO-2022-1080

## What is CVE-2022-39341?

CVE-2022-39341 is a medium-severity authentication bypass vulnerability in openfga, published on 25 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenFGA is an authorization/permission engine. Versions prior to version 0.2.4 are vulnerable to authorization bypass under certain conditions. Users who have wildcard (`*`) defined on tupleset relations in their authorization model are vulnerable. Version 0.2.4 contains a patch for this issue.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2022-39341?

3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openfga/openfga` | Go | All versions | 0.2.4 |
| `github.com/openfga/openfga` | Go | All versions | 0.2.4 |
| `github.com/openfga/openfga` | Go | All versions | 0.2.4 |

Products: Openfga Openfga.

## How do I fix CVE-2022-39341?

Upgrade github.com/openfga/openfga to 0.2.4 or later.

## Is CVE-2022-39341 being exploited?

There is no known exploitation of CVE-2022-39341 in the wild and no public exploit code.

## Other vulnerabilities in openfga

- [CVE-2024-31452](https://insights.sbomify.com/CVE-2024-31452/): OpenFGA Authorization Bypass (high 8.1)
- [CVE-2022-23542](https://insights.sbomify.com/CVE-2022-23542/): OpenFGA Authorization Bypass (high 7.7)
- [CVE-2024-42473](https://insights.sbomify.com/CVE-2024-42473/): OpenFGA Authorization Bypass (high 7.5)
- [CVE-2026-40293](https://insights.sbomify.com/CVE-2026-40293/): OpenFGA Playground Preshared Key Exposure (medium 6.5)
- [CVE-2023-40579](https://insights.sbomify.com/CVE-2023-40579/): OpenFGA Authorization Bypass (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39341 and fix it if it is affected.

What it is: CVE-2022-39341 is a medium-severity authentication bypass vulnerability in openfga, published on 25 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39341 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openfga/openfga (Go): affected all versions; fixed in 0.2.4
- github.com/openfga/openfga (Go): affected all versions; fixed in 0.2.4
- github.com/openfga/openfga (Go): affected all versions; fixed in 0.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39341/ (Markdown: https://insights.sbomify.com/CVE-2022-39341/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39341
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39341
- OSV: https://osv.dev/vulnerability/CVE-2022-39341

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39341/
Summaries are generated and may contain mistakes; the official description above is the record.
