{"answers":{"affected":"2 open source packages ship an affected version, including @dependencytrack/frontend. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-39350 in the wild and no public exploit code.","fix":"Upgrade @dependencytrack/frontend to 4.6.1 or later.","what":"CVE-2022-39350 is a medium-severity cross-site scripting vulnerability in DependencyTrack frontend, published on 25 Oct 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-39350 and fix it if it is affected.\n\nWhat it is: CVE-2022-39350 is a medium-severity cross-site scripting vulnerability in DependencyTrack frontend, published on 25 Oct 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-39350 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @dependencytrack/frontend (npm): affected all versions; fixed in 4.6.1\n- @dependencytrack/frontend (npm): affected all versions; fixed in 4.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-39350/ (Markdown: https://insights.sbomify.com/CVE-2022-39350/index.md)","id":"CVE-2022-39350","markdown":"https://insights.sbomify.com/CVE-2022-39350/index.md","name":"CVE-2022-39350","record":{"aliases":["GHSA-c33w-pm52-mqvf"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Dependency-Track frontend","requires_auth":"low_privilege","summary":"Attackers with vulnerability management permissions can inject malicious scripts into vulnerability details, executing them for other users viewing the page.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"dependency-track_frontend","vendor":"owasp"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"@dependencytrack/frontend is a Single Page Application (SPA) used in Dependency-Track, an open source Component Analysis platform that allows organizations to identify and reduce risk in the software supply chain. Due to the common practice of providing vulnerability details in markdown format, the Dependency-Track frontend renders them using the JavaScript library Showdown. Showdown does not have any XSS countermeasures built in, and versions before 4.6.1 of the Dependency-Track frontend did not encode or sanitize Showdown's output. This made it possible for arbitrary JavaScript included in vulnerability details via HTML attributes to be executed in context of the frontend. Actors with the `VULNERABILITY_MANAGEMENT` permission can exploit this weakness by creating or editing a custom vulnerability and providing XSS payloads in any of the following fields: Description, Details, Recommendation, or References. The payload will be executed for users with the `VIEW_PORTFOLIO` permission when browsing to the modified vulnerability's page. Alternatively, malicious JavaScript could be introduced via any of the vulnerability databases mirrored by Dependency-Track. However, this attack vector is highly unlikely, and the maintainers of Dependency-Track are not aware of any occurrence of this happening. Note that the `Vulnerability Details` element of the `Audit Vulnerabilities` tab in the project view is not affected. The issue has been fixed in frontend version 4.6.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"@dependencytrack/frontend vulnerable to Persistent Cross-Site-Scripting via Vulnerability Details","id":"CVE-2022-39350","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Information disclosure in dependency-track","id":"CVE-2022-39351"},"packages":[{"ecosystem":"npm","fixed":["4.6.1"],"introduced":["0"],"last_affected":[],"package":"@dependencytrack/frontend","purl":null,"source":"GHSA-c33w-pm52-mqvf"},{"ecosystem":"npm","fixed":["4.6.1"],"introduced":["0"],"last_affected":[],"package":"@dependencytrack/frontend","purl":"pkg:npm/%40dependencytrack/frontend","source":"GHSA-c33w-pm52-mqvf"}],"prev":{"headline":"Tasks.org vulnerable to data exfiltration by malicous app or adb","id":"CVE-2022-39349"},"products":["frontend"],"published":"2022-10-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["DependencyTrack"]},"summary":"Attackers with vulnerability management permissions can inject malicious scripts into vulnerability details, executing them for other users viewing the page.","url":"https://insights.sbomify.com/CVE-2022-39350/"}