# CVE-2022-39350: @dependencytrack/frontend vulnerable to Persistent Cross-Site-Scripting via Vulnerability Details

> Attackers with vulnerability management permissions can inject malicious scripts into vulnerability details, executing them for other users viewing the page.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Oct 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-c33w-pm52-mqvf

## What is CVE-2022-39350?

CVE-2022-39350 is a medium-severity cross-site scripting vulnerability in DependencyTrack frontend, published on 25 Oct 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

@dependencytrack/frontend is a Single Page Application (SPA) used in Dependency-Track, an open source Component Analysis platform that allows organizations to identify and reduce risk in the software supply chain. Due to the common practice of providing vulnerability details in markdown format, the Dependency-Track frontend renders them using the JavaScript library Showdown. Showdown does not have any XSS countermeasures built in, and versions before 4.6.1 of the Dependency-Track frontend did not encode or sanitize Showdown's output. This made it possible for arbitrary JavaScript included in vulnerability details via HTML attributes to be executed in context of the frontend. Actors with the `VULNERABILITY_MANAGEMENT` permission can exploit this weakness by creating or editing a custom vulnerability and providing XSS payloads in any of the following fields: Description, Details, Recommendation, or References. The payload will be executed for users with the `VIEW_PORTFOLIO` permission when browsing to the modified vulnerability's page. Alternatively, malicious JavaScript could be introduced via any of the vulnerability databases mirrored by Dependency-Track. However, this attack vector is highly unlikely, and the maintainers of Dependency-Track are not aware of any occurrence of this happening. Note that the `Vulnerability Details` element of the `Audit Vulnerabilities` tab in the project view is not affected. The issue has been fixed in frontend version 4.6.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-39350?

2 open source packages ship an affected version, including @dependencytrack/frontend. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@dependencytrack/frontend` | npm | All versions | 4.6.1 |
| `@dependencytrack/frontend` | npm | All versions | 4.6.1 |

Products: Owasp Dependency-Track Frontend.

## How do I fix CVE-2022-39350?

Upgrade @dependencytrack/frontend to 4.6.1 or later.

## Is CVE-2022-39350 being exploited?

There is no known exploitation of CVE-2022-39350 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39350 and fix it if it is affected.

What it is: CVE-2022-39350 is a medium-severity cross-site scripting vulnerability in DependencyTrack frontend, published on 25 Oct 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-39350 in the wild and no public exploit code.

Affected packages and fixed versions:
- @dependencytrack/frontend (npm): affected all versions; fixed in 4.6.1
- @dependencytrack/frontend (npm): affected all versions; fixed in 4.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39350/ (Markdown: https://insights.sbomify.com/CVE-2022-39350/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39350
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39350
- OSV: https://osv.dev/vulnerability/CVE-2022-39350

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39350/
Summaries are generated and may contain mistakes; the official description above is the record.
