# CVE-2022-39352: OpenFGA Authorization Bypass


- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 8 Nov 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-3gfj-fxx4-f22w, GO-2022-1099

## What is CVE-2022-39352?

CVE-2022-39352 is a medium-severity vulnerability in openfga, published on 8 Nov 2022. 

### Official description

OpenFGA is a high-performance authorization/permission engine inspired by Google Zanzibar. Versions prior to 0.2.5 are vulnerable to authorization bypass under certain conditions. You are affected by this vulnerability if you added a tuple with a wildcard (*) assigned to a tupleset relation (the right hand side of a ‘from’ statement). This issue has been patched in version v0.2.5. This update is not backward compatible with any authorization model that uses wildcard on a tupleset relation.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2022-39352?

3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openfga/openfga` | Go | All versions | 0.2.5 |
| `github.com/openfga/openfga` | Go | All versions | 0.2.5 |
| `github.com/openfga/openfga` | Go | All versions | 0.2.5 |

Products: Openfga Openfga.

## How do I fix CVE-2022-39352?

Upgrade github.com/openfga/openfga to 0.2.5 or later.

## Is CVE-2022-39352 being exploited?

There is no known exploitation of CVE-2022-39352 in the wild and no public exploit code.

## Other vulnerabilities in openfga

- [CVE-2024-31452](https://insights.sbomify.com/CVE-2024-31452/): OpenFGA Authorization Bypass (high 8.1)
- [CVE-2022-23542](https://insights.sbomify.com/CVE-2022-23542/): OpenFGA Authorization Bypass (high 7.7)
- [CVE-2024-42473](https://insights.sbomify.com/CVE-2024-42473/): OpenFGA Authorization Bypass (high 7.5)
- [CVE-2026-40293](https://insights.sbomify.com/CVE-2026-40293/): OpenFGA Playground Preshared Key Exposure (medium 6.5)
- [CVE-2023-40579](https://insights.sbomify.com/CVE-2023-40579/): OpenFGA Authorization Bypass (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39352 and fix it if it is affected.

What it is: CVE-2022-39352 is a medium-severity vulnerability in openfga, published on 8 Nov 2022. 
Exploitation: There is no known exploitation of CVE-2022-39352 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openfga/openfga (Go): affected all versions; fixed in 0.2.5
- github.com/openfga/openfga (Go): affected all versions; fixed in 0.2.5
- github.com/openfga/openfga (Go): affected all versions; fixed in 0.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39352/ (Markdown: https://insights.sbomify.com/CVE-2022-39352/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39352
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39352
- OSV: https://osv.dev/vulnerability/CVE-2022-39352

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39352/
Summaries are generated and may contain mistakes; the official description above is the record.
