# CVE-2022-39353: xmldom allows multiple root nodes in a DOM

> The xmldom library incorrectly parses XML with multiple root nodes, potentially causing logic errors in dependent applications that assume a single root.

- **Severity:** Critical 9.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Nov 2022
- **Updated:** 22 Apr 2025
- **Also known as:** AZL-38671, DEBIAN-CVE-2022-39353, GHSA-crh6-fp67-6883, UBUNTU-CVE-2022-39353

## What is CVE-2022-39353?

CVE-2022-39353 is a critical vulnerability in Debian Debian Linux, published on 2 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) `DOMParser` and `XMLSerializer` module. xmldom parses XML that is not well-formed because it contains multiple top level elements, and adds all root nodes to the `childNodes` collection of the `Document`, without reporting any error or throwing. This breaks the assumption that there is only a single root node in the tree, which led to issuance of CVE-2022-39299 as it is a potential issue for dependents. Update to @xmldom/xmldom@~0.7.7, @xmldom/xmldom@~0.8.4 (dist-tag latest) or @xmldom/xmldom@>=0.9.0-beta.4 (dist-tag next). As a workaround, please one of the following approaches depending on your use case: instead of searching for elements in the whole DOM, only search in the `documentElement`or reject a document with a document that has more then 1 `childNode`.

Weakness: CWE-20 (Improper Input Validation), CWE-1288 (Improper Validation of Consistency within Input)

## Which versions are affected by CVE-2022-39353?

8 open source packages ship an affected version, including @xmldom/xmldom and xmldom. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@xmldom/xmldom` | npm | All versions | 0.7.7 |
| `@xmldom/xmldom` | npm | All versions | 0.7.7 |
| `@xmldom/xmldom` | npm | From 0.8.0 | 0.8.4 |
| `@xmldom/xmldom` | npm | From 0.8.0 | 0.8.4 |
| `@xmldom/xmldom` | npm | From 0.9.0-beta.1 | 0.9.0-beta.4 |
| `@xmldom/xmldom` | npm | From 0.9.0-beta.1 | 0.9.0-beta.4 |
| `xmldom` | npm | All versions to 0.6.0 | None |
| `xmldom` | npm | All versions to 0.6.0 | None |

Products: Debian Debian Linux, Xmldom Project Xmldom.

## How do I fix CVE-2022-39353?

Upgrade @xmldom/xmldom to a fixed version for your release line: 0.7.7, 0.8.4 or 0.9.0-beta.4.

## Is CVE-2022-39353 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39353 exists.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39353 and fix it if it is affected.

What it is: CVE-2022-39353 is a critical vulnerability in Debian Debian Linux, published on 2 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39353 exists.

Affected packages and fixed versions:
- @xmldom/xmldom (npm): affected all versions; fixed in 0.7.7
- @xmldom/xmldom (npm): affected all versions; fixed in 0.7.7
- @xmldom/xmldom (npm): affected from 0.8.0; fixed in 0.8.4
- @xmldom/xmldom (npm): affected from 0.8.0; fixed in 0.8.4
- @xmldom/xmldom (npm): affected from 0.9.0-beta.1; fixed in 0.9.0-beta.4
- @xmldom/xmldom (npm): affected from 0.9.0-beta.1; fixed in 0.9.0-beta.4
- xmldom (npm): affected all versions up to 0.6.0; no fix listed
- xmldom (npm): affected all versions up to 0.6.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39353/ (Markdown: https://insights.sbomify.com/CVE-2022-39353/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39353
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39353
- OSV: https://osv.dev/vulnerability/CVE-2022-39353

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39353/
Summaries are generated and may contain mistakes; the official description above is the record.
