# CVE-2022-39357: Winter vulnerable to Prototype Pollution in Snowboard framework

> Prototype pollution in Winter CMS Snowboard framework allows attackers to manipulate objects, potentially leading to code execution or privilege escalation.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Oct 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-3fh5-q6fg-w28q

## What is CVE-2022-39357?

CVE-2022-39357 is a high-severity vulnerability in wintercms winter, published on 26 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Winter is a free, open-source content management system based on the Laravel PHP framework. The Snowboard framework in versions 1.1.8, 1.1.9, and 1.2.0 is vulnerable to prototype pollution in the main Snowboard class as well as its plugin loader. The 1.0 branch of Winter is not affected, as it does not contain the Snowboard framework. This issue has been patched in v1.1.10 and v1.2.1. As a workaround, one may avoid this issue by following some common security practices for JavaScript, including implementing a content security policy and auditing scripts.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2022-39357?

4 open source packages ship an affected version, including wintercms/winter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wintercms/winter` | Packagist | From 1.1.8 | 1.1.10 |
| `wintercms/winter` | Packagist | From 1.1.8 | 1.1.10 |
| `wintercms/winter` | Packagist | From 1.2.0 | 1.2.1 |
| `wintercms/winter` | Packagist | From 1.2.0 | 1.2.1 |

Products: Wintercms Winter.

## How do I fix CVE-2022-39357?

Upgrade wintercms/winter to a fixed version for your release line: 1.1.10 or 1.2.1.

## Is CVE-2022-39357 being exploited?

There is no known exploitation of CVE-2022-39357 in the wild and no public exploit code.

## Other vulnerabilities in wintercms winter

- [CVE-2026-27591](https://insights.sbomify.com/CVE-2026-27591/): Winter: Privilege escalation by authenticated backend users (critical 10.0)
- [CVE-2024-54149](https://insights.sbomify.com/CVE-2024-54149/): Winter CMS Modules allows a sandbox bypass in Twig templates leading to data modification and deletion (high 8.5)
- [CVE-2024-29686](https://insights.sbomify.com/CVE-2024-29686/): Winter CMS Server-Side Template Injection (SSTI) vulnerability (high 7.2)
- [CVE-2023-52085](https://insights.sbomify.com/CVE-2023-52085/): Winter CMS Local File Inclusion through Server Side Template Injection (low 3.3)
- [CVE-2023-52083](https://insights.sbomify.com/CVE-2023-52083/): Stored XSS through privileged upload of Media Manager file followed by renaming (low 2.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39357 and fix it if it is affected.

What it is: CVE-2022-39357 is a high-severity vulnerability in wintercms winter, published on 26 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39357 in the wild and no public exploit code.

Affected packages and fixed versions:
- wintercms/winter (Packagist): affected from 1.1.8; fixed in 1.1.10
- wintercms/winter (Packagist): affected from 1.1.8; fixed in 1.1.10
- wintercms/winter (Packagist): affected from 1.2.0; fixed in 1.2.1
- wintercms/winter (Packagist): affected from 1.2.0; fixed in 1.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39357/ (Markdown: https://insights.sbomify.com/CVE-2022-39357/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39357
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39357
- OSV: https://osv.dev/vulnerability/CVE-2022-39357

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39357/
Summaries are generated and may contain mistakes; the official description above is the record.
