CVE-2022-39358 Metabase vulnerable to circumvention of Locked parameter in Signed Embedding
Attackers can bypass locked parameter restrictions in embedded dashboards to access unauthorized data, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2022-39358?
CVE-2022-39358 is a medium-severity vulnerability in metabase, published on 26 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Metabase is data visualization software. Prior to versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, and 1.42.6, it was possible to circumvent locked parameters when requesting data for a question in an embedded dashboard by constructing a malicious request to the backend. This issue is patched in versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, and 1.42.6.
Which versions are affected by CVE-2022-39358?
It affects 1 product.
Products include Metabase Metabase.
How do I fix CVE-2022-39358?
No fix has been published for CVE-2022-39358 yet. Limit exposure of the affected software until one is available.
Is CVE-2022-39358 being exploited?
There is no known exploitation of CVE-2022-39358 in the wild and no public exploit code.
Other vulnerabilities in metabase
- CVE-2026-72898 Metabase SQL Injection
- CVE-2021-41277 Metabase GeoJSON API Local File Inclusion
- CVE-2026-50148 Metabase: Remote Code Execution via Snowflake JDBC Driver Arbitrary File Write
- CVE-2023-37470 Metabase vulnerable to remote code execution via POST /api/setup/validate API endpoint
- CVE-2026-59827 Metabase: Unsafe Deserialization of H2 Query Results
Sources
Also known as GHSA-8qgm-9mj6-36h3.