# CVE-2022-39360: Metabase SSO users able to circumvent IdP login by doing password reset

> SSO users can bypass identity provider authentication by triggering password resets, allowing unauthorized access to Metabase accounts.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 Oct 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-gw4g-ww2m-v7vc

## What is CVE-2022-39360?

CVE-2022-39360 is a medium-severity authentication bypass vulnerability in metabase, published on 26 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Metabase is data visualization software. Prior to versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9 single sign on (SSO) users were able to do password resets on Metabase, which could allow a user access without going through the SSO IdP. This issue is patched in versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9. Metabase now blocks password reset for all users who use SSO for their Metabase login.

Weakness: CWE-304 (Missing Critical Step in Authentication), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2022-39360?

It affects 1 product.


Products: Metabase Metabase.

## How do I fix CVE-2022-39360?

No fix has been published for CVE-2022-39360 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-39360 being exploited?

There is no known exploitation of CVE-2022-39360 in the wild and no public exploit code.

## Other vulnerabilities in metabase

- [CVE-2026-72898](https://insights.sbomify.com/CVE-2026-72898/): Metabase SQL Injection (critical 10.0, exploited in the wild)
- [CVE-2021-41277](https://insights.sbomify.com/CVE-2021-41277/): Metabase GeoJSON API Local File Inclusion (critical 10.0, exploited in the wild)
- [CVE-2026-50148](https://insights.sbomify.com/CVE-2026-50148/): Metabase: Remote Code Execution via Snowflake JDBC Driver Arbitrary File Write (critical 10.0)
- [CVE-2023-37470](https://insights.sbomify.com/CVE-2023-37470/): Metabase vulnerable to remote code execution via POST /api/setup/validate API endpoint (critical 10.0)
- [CVE-2026-59827](https://insights.sbomify.com/CVE-2026-59827/): Metabase: Unsafe Deserialization of H2 Query Results (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39360 and fix it if it is affected.

What it is: CVE-2022-39360 is a medium-severity authentication bypass vulnerability in metabase, published on 26 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39360 in the wild and no public exploit code.

Affected product: metabase. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39360/ (Markdown: https://insights.sbomify.com/CVE-2022-39360/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39360
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39360
- OSV: https://osv.dev/vulnerability/CVE-2022-39360

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39360/
Summaries are generated and may contain mistakes; the official description above is the record.
