CVE-2022-39361 Metabase vulnerable to Remote Code Execution via H2
Attackers with SQL query access can execute arbitrary code via H2 database features, requiring an upgrade to patched Metabase versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2022-39361?
CVE-2022-39361 is a high-severity code injection vulnerability in metabase, published on 26 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Metabase is data visualization software. Prior to versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9, H2 (Sample Database) could allow Remote Code Execution (RCE), which can be abused by users able to write SQL queries on H2 databases. This issue is patched in versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9. Metabase no longer allows DDL statements in H2 native queries.
Which versions are affected by CVE-2022-39361?
It affects 1 product.
Products include Metabase Metabase.
How do I fix CVE-2022-39361?
No fix has been published for CVE-2022-39361 yet. Limit exposure of the affected software until one is available.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2022-39361 being exploited?
There is no known exploitation of CVE-2022-39361 in the wild and no public exploit code.
Other vulnerabilities in metabase
- CVE-2026-72898 Metabase SQL Injection
- CVE-2021-41277 Metabase GeoJSON API Local File Inclusion
- CVE-2026-50148 Metabase: Remote Code Execution via Snowflake JDBC Driver Arbitrary File Write
- CVE-2023-37470 Metabase vulnerable to remote code execution via POST /api/setup/validate API endpoint
- CVE-2026-59827 Metabase: Unsafe Deserialization of H2 Query Results
Sources
Also known as GHSA-gqpj-wcr3-p88v.