{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-39361 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2022-39361 yet. Limit exposure of the affected software until one is available.","what":"CVE-2022-39361 is a high-severity code injection vulnerability in metabase, published on 26 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-39361 and fix it if it is affected.\n\nWhat it is: CVE-2022-39361 is a high-severity code injection vulnerability in metabase, published on 26 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-39361 in the wild and no public exploit code.\n\nAffected product: metabase. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-39361/ (Markdown: https://insights.sbomify.com/CVE-2022-39361/index.md)","id":"CVE-2022-39361","markdown":"https://insights.sbomify.com/CVE-2022-39361/index.md","name":"CVE-2022-39361","record":{"aliases":["GHSA-gqpj-wcr3-p88v"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Metabase data visualization","requires_auth":"low_privilege","summary":"Attackers with SQL query access can execute arbitrary code via H2 database features, requiring an upgrade to patched Metabase versions.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"metabase","vendor":"metabase"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-441","name":"Unintended Proxy or Intermediary"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Metabase is data visualization software. Prior to versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9, H2 (Sample Database) could allow Remote Code Execution (RCE), which can be abused by users able to write SQL queries on H2 databases. This issue is patched in versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9. Metabase no longer allows DDL statements in H2 native queries.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Metabase vulnerable to Remote Code Execution via H2","id":"CVE-2022-39361","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2022"},"n_packages":0,"n_references":1,"next":{"headline":"Metabase vulnerable to arbitrary SQL execution from queryhash","id":"CVE-2022-39362"},"packages":[],"prev":{"headline":"Metabase SSO users able to circumvent IdP login by doing password reset","id":"CVE-2022-39360"},"products":["metabase"],"published":"2022-10-26","related":[{"cvss_score":10,"headline":"Metabase SQL Injection","id":"CVE-2026-72898","kev_date_added":"2026-08-11","published":"2026-08-10"},{"cvss_score":10,"headline":"Metabase GeoJSON API Local File Inclusion","id":"CVE-2021-41277","kev_date_added":"2024-11-12","published":"2021-11-17"},{"cvss_score":10,"headline":"Metabase: Remote Code Execution via Snowflake JDBC Driver Arbitrary File Write","id":"CVE-2026-50148","kev_date_added":null,"published":"2026-07-15"},{"cvss_score":10,"headline":"Metabase vulnerable to remote code execution via POST /api/setup/validate API endpoint","id":"CVE-2023-37470","kev_date_added":null,"published":"2023-08-04"},{"cvss_score":9.9,"headline":"Metabase: Unsafe Deserialization of H2 Query Results","id":"CVE-2026-59827","kev_date_added":null,"published":"2026-07-09"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2023-38646","kev_date_added":null,"published":"2023-07-21"},{"cvss_score":9.1,"headline":"Metabase: Arbitrary Code Execution via Database Connection Detail Bypass","id":"CVE-2026-59826","kev_date_added":null,"published":"2026-07-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["metabase"]},"summary":"Attackers with SQL query access can execute arbitrary code via H2 database features, requiring an upgrade to patched Metabase versions.","url":"https://insights.sbomify.com/CVE-2022-39361/"}