CVE-2022-39362 Metabase vulnerable to arbitrary SQL execution from queryhash

High 8.8 Published Updated

Attackers can execute arbitrary SQL queries via unsaved query hashes in Metabase, potentially leading to data access or code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2022-39362?

CVE-2022-39362 is a high-severity SQL injection vulnerability in metabase, published on 26 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Metabase is data visualization software. Prior to versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9, unsaved SQL queries are auto-executed, which could pose a possible attack vector. This issue is patched in versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9. Metabase no longer automatically executes ad-hoc native queries. Now the native editor shows the query and gives the user the option to manually run the query if they want.

Weakness: CWE-356

Which versions are affected by CVE-2022-39362?

It affects 1 product.

Products include Metabase Metabase.

How do I fix CVE-2022-39362?

No fix has been published for CVE-2022-39362 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2022-39362 being exploited?

There is no known exploitation of CVE-2022-39362 in the wild and no public exploit code.

Sources

Also known as GHSA-93wj-fgjg-r238.

Is CVE-2022-39362 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free