# CVE-2022-39365: RCE vulnerability in Pimcore/Mail & Dynamic Text Layout

> Attackers can achieve remote code execution via server-side template injection in Pimcore's mail and text layout features.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Oct 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-5qxq-vgmm-q39m

## What is CVE-2022-39365?

CVE-2022-39365 is a critical code injection vulnerability in Pimcore Pimcore, published on 27 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pimcore is an open source data and experience management platform. Prior to version 10.5.9, the user controlled twig templates rendering in `Pimcore/Mail` & `ClassDefinition\Layout\Text` is vulnerable to server-side template injection, which could lead to remote code execution. Version 10.5.9 contains a patch for this issue. As a workaround, one may apply the patch manually.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2022-39365?

2 open source packages ship an affected version, including pimcore/pimcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/pimcore` | Packagist | All versions | 10.5.9 |
| `pimcore/pimcore` | Packagist | All versions | 10.5.9 |

Products: Pimcore Pimcore.

## How do I fix CVE-2022-39365?

Upgrade pimcore/pimcore to 10.5.9 or later.

## Is CVE-2022-39365 being exploited?

There is no known exploitation of CVE-2022-39365 in the wild and no public exploit code.

## Other vulnerabilities in Pimcore Pimcore

- [CVE-2019-18981](https://insights.sbomify.com/CVE-2019-18981/): Pimcore Access Control Issues (critical 9.8)
- [CVE-2019-18985](https://insights.sbomify.com/CVE-2019-18985/): Pimcore 2FA Vulnerable to Brute Forcing (critical 9.8)
- [CVE-2026-23492](https://insights.sbomify.com/CVE-2026-23492/): Pimcore has a Blind SQL Injection in Admin Search Find API due to an incomplete fix for CVE-2023-30848 (high 8.8)
- [CVE-2023-47637](https://insights.sbomify.com/CVE-2023-47637/): SQL Injection in Admin Grid Filter API in Pimcore (high 8.8)
- [CVE-2023-30848](https://insights.sbomify.com/CVE-2023-30848/): Pimcore SQL Injection Vulnerability in Admin Search Find API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39365 and fix it if it is affected.

What it is: CVE-2022-39365 is a critical code injection vulnerability in Pimcore Pimcore, published on 27 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39365 in the wild and no public exploit code.

Affected packages and fixed versions:
- pimcore/pimcore (Packagist): affected all versions; fixed in 10.5.9
- pimcore/pimcore (Packagist): affected all versions; fixed in 10.5.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39365/ (Markdown: https://insights.sbomify.com/CVE-2022-39365/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39365
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39365
- OSV: https://osv.dev/vulnerability/CVE-2022-39365

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39365/
Summaries are generated and may contain mistakes; the official description above is the record.
