# CVE-2022-39366: DataHub missing JWT signature check

> Attackers can bypass authentication and impersonate any user in DataHub if Metadata Service authentication is enabled, due to missing JWT signature verification.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Oct 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-r8gm-v65f-c973, PYSEC-2026-252

## What is CVE-2022-39366?

CVE-2022-39366 is a critical authentication bypass vulnerability in datahub-project datahub, published on 28 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

DataHub is an open-source metadata platform. Prior to version 0.8.45, the `StatelessTokenService` of the DataHub metadata service (GMS) does not verify the signature of JWT tokens. This allows an attacker to connect to DataHub instances as any user if Metadata Service authentication is enabled. This vulnerability occurs because the `StatelessTokenService` of the Metadata service uses the `parse` method of `io.jsonwebtoken.JwtParser`, which does not perform a verification of the cryptographic token signature. This means that JWTs are accepted regardless of the used algorithm. This issue may lead to an authentication bypass. Version 0.8.45 contains a patch for the issue. There are no known workarounds.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature), CWE-303 (Incorrect Implementation of Authentication Algorithm), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2022-39366?

3 open source packages ship an affected version, including acryl-datahub. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `acryl-datahub` | PyPI | All versions | 0.8.45 |
| `acryl-datahub` | PyPI | All versions | 0.8.45 |
| `acryl-datahub` | PyPI | All versions | 0.8.45 |

Products: Datahub Datahub.

## How do I fix CVE-2022-39366?

Upgrade acryl-datahub to 0.8.45 or later.

## Is CVE-2022-39366 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39366 exists.

## Other vulnerabilities in datahub-project datahub

- [CVE-2023-25559](https://insights.sbomify.com/CVE-2023-25559/): System account impersonation in DataHub (high 8.2)
- [CVE-2023-25560](https://insights.sbomify.com/CVE-2023-25560/): JSON Injection in DataHub (high 8.2)
- [CVE-2026-25644](https://insights.sbomify.com/CVE-2026-25644/): DataHub's LDAP Ingestion Source vulnerable to MITM attack through TLS downgrade (high 7.5)
- [CVE-2023-25557](https://insights.sbomify.com/CVE-2023-25557/): Server-Side Request Forgery in DataHub (high 7.5)
- [CVE-2023-25562](https://insights.sbomify.com/CVE-2023-25562/): Failure to Invalidate Session on Logout in DataHub (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39366 and fix it if it is affected.

What it is: CVE-2022-39366 is a critical authentication bypass vulnerability in datahub-project datahub, published on 28 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39366 exists.

Affected packages and fixed versions:
- acryl-datahub (PyPI): affected all versions; fixed in 0.8.45
- acryl-datahub (PyPI): affected all versions; fixed in 0.8.45
- acryl-datahub (PyPI): affected all versions; fixed in 0.8.45

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39366/ (Markdown: https://insights.sbomify.com/CVE-2022-39366/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39366
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39366
- OSV: https://osv.dev/vulnerability/CVE-2022-39366

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39366/
Summaries are generated and may contain mistakes; the official description above is the record.
