# CVE-2022-39367: Vulnerability in handling of uploaded QTI ZIP files

> Attackers can upload malicious ZIP files to write arbitrary files to the filesystem, potentially leading to code execution or data modification.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 28 Oct 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-xrjg-59rc-4j42

## What is CVE-2022-39367?

CVE-2022-39367 is a high-severity path traversal vulnerability in davemckain qtiworks, published on 28 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

QTIWorks is a software suite for standards-based assessment delivery. Prior to version 1.0-beta15, the QTIWorks Engine allows users to upload QTI content packages as ZIP files. The ZIP handling code does not sufficiently check the paths of files contained within ZIP files, so can insert files into other locations in the filesystem if they are writable by the process running the QTIWorks Engine. In extreme cases, this could allow anonymous users to change files in arbitrary locations in the filesystem. In normal QTIWorks Engine deployments, the impact is somewhat reduced because the default QTIWorks configuration does not enable the public demo functionality, so ZIP files can only be uploaded by users with "instructor" privileges. This vulnerability is fixed in version 1.0-beta15. There are no database configuration changes required when upgrading to this version. No known workarounds for this issue exist.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-39367?

It affects 1 product.


Products: Qtiworks Project Qtiworks.

## How do I fix CVE-2022-39367?

No fix has been published for CVE-2022-39367 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-39367 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39367 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39367 and fix it if it is affected.

What it is: CVE-2022-39367 is a high-severity path traversal vulnerability in davemckain qtiworks, published on 28 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39367 exists.

Affected product: davemckain qtiworks. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39367/ (Markdown: https://insights.sbomify.com/CVE-2022-39367/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39367
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39367
- OSV: https://osv.dev/vulnerability/CVE-2022-39367

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39367/
Summaries are generated and may contain mistakes; the official description above is the record.
