CVE-2022-39368 Californium Failing DTLS handshakes causes Data Loss due to throttling blocking processing of records
Attackers can cause permanent data loss and service disruption in Eclipse Californium by triggering failed DTLS handshakes that exhaust throttling counters.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-39368?
CVE-2022-39368 is a high-severity denial of service vulnerability in eclipse-californium californium, published on 9 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Eclipse Californium is a Java implementation of RFC7252 - Constrained Application Protocol for IoT Cloud services. In versions prior to 3.7.0, and 2.7.4, Californium is vulnerable to a Denial of Service. Failing handshakes don't cleanup counters for throttling, causing the threshold to be reached without being released again. This results in permanently dropping records. The issue was reported for certificate based handshakes, but may also affect PSK based handshakes. It generally affects client and server as well. This issue is patched in version 3.7.0 and 2.7.4. There are no known workarounds. main: commit 726bac57659410da463dcf404b3e79a7312ac0b9 2.7.x: commit 5648a0c27c2c2667c98419254557a14bac2b1f3f
Which versions are affected by CVE-2022-39368?
4 open source packages ship an affected version, including org.eclipse.californium:scandium. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.eclipse.californium:scandium Maven | From 2.7.0 | 2.7.4 |
org.eclipse.californium:scandium Maven | From 2.7.0 | 2.7.4 |
org.eclipse.californium:scandium Maven | From 3.0.0 | 3.7.0 |
org.eclipse.californium:scandium Maven | From 3.0.0 | 3.7.0 |
Products include Eclipse Californium.
How do I fix CVE-2022-39368?
Upgrade org.eclipse.californium:scandium to a fixed version for your release line: 2.7.4 or 3.7.0.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-39368 being exploited?
There is no known exploitation of CVE-2022-39368 in the wild and no public exploit code.
Other vulnerabilities in eclipse-californium californium
Sources
Also known as GHSA-p72g-cgh9-ghjg.