# CVE-2022-39368: Californium Failing DTLS handshakes causes Data Loss due to throttling blocking processing of records

> Attackers can cause permanent data loss and service disruption in Eclipse Californium by triggering failed DTLS handshakes that exhaust throttling counters.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Nov 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-p72g-cgh9-ghjg

## What is CVE-2022-39368?

CVE-2022-39368 is a high-severity denial of service vulnerability in eclipse-californium californium, published on 9 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Eclipse Californium is a Java implementation of RFC7252 - Constrained Application Protocol for IoT Cloud services. In versions prior to 3.7.0, and 2.7.4, Californium is vulnerable to a Denial of Service. Failing handshakes don't cleanup counters for throttling, causing the threshold to be reached without being released again. This results in permanently dropping records. The issue was reported for certificate based handshakes, but may also affect PSK based handshakes. It generally affects client and server as well. This issue is patched in version 3.7.0 and 2.7.4. There are no known workarounds. main: commit 726bac57659410da463dcf404b3e79a7312ac0b9 2.7.x: commit 5648a0c27c2c2667c98419254557a14bac2b1f3f

Weakness: CWE-459 (Incomplete Cleanup), CWE-404 (Improper Resource Shutdown or Release)

## Which versions are affected by CVE-2022-39368?

4 open source packages ship an affected version, including org.eclipse.californium:scandium. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.californium:scandium` | Maven | From 2.7.0 | 2.7.4 |
| `org.eclipse.californium:scandium` | Maven | From 2.7.0 | 2.7.4 |
| `org.eclipse.californium:scandium` | Maven | From 3.0.0 | 3.7.0 |
| `org.eclipse.californium:scandium` | Maven | From 3.0.0 | 3.7.0 |

Products: Eclipse Californium.

## How do I fix CVE-2022-39368?

Upgrade org.eclipse.californium:scandium to a fixed version for your release line: 2.7.4 or 3.7.0.

## Is CVE-2022-39368 being exploited?

There is no known exploitation of CVE-2022-39368 in the wild and no public exploit code.

## Other vulnerabilities in eclipse-californium californium

- [CVE-2022-2576](https://insights.sbomify.com/CVE-2022-2576/): Eclipse Californium denial of service (DoS) via Datagram Transport Layer Security (DTLS) handshake on parameter mismatch (high 7.5)
- [CVE-2021-34433](https://insights.sbomify.com/CVE-2021-34433/): Auth bypass in Eclipse Californium (high 7.5)
- [CVE-2020-27222](https://insights.sbomify.com/CVE-2020-27222/): Denial of service in Eclipse Californium (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39368 and fix it if it is affected.

What it is: CVE-2022-39368 is a high-severity denial of service vulnerability in eclipse-californium californium, published on 9 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39368 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.eclipse.californium:scandium (Maven): affected from 2.7.0; fixed in 2.7.4
- org.eclipse.californium:scandium (Maven): affected from 2.7.0; fixed in 2.7.4
- org.eclipse.californium:scandium (Maven): affected from 3.0.0; fixed in 3.7.0
- org.eclipse.californium:scandium (Maven): affected from 3.0.0; fixed in 3.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39368/ (Markdown: https://insights.sbomify.com/CVE-2022-39368/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39368
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39368
- OSV: https://osv.dev/vulnerability/CVE-2022-39368

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39368/
Summaries are generated and may contain mistakes; the official description above is the record.
