CVE-2022-39377 sysstat Incorrect Buffer Size calculation on 32-bit systems results in RCE via buffer overflow
An integer overflow in sysstat on 32-bit Linux systems allows remote attackers to execute arbitrary code via a buffer overflow.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-39377?
CVE-2022-39377 is a high-severity vulnerability in Debian Debian Linux, published on 8 Nov 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
sysstat is a set of system performance tools for the Linux operating system. On 32 bit systems, in versions 9.1.16 and newer but prior to 12.7.1, allocate_structures contains a size_t overflow in sa_common.c. The allocate_structures function insufficiently checks bounds before arithmetic multiplication, allowing for an overflow in the size allocated for the buffer representing system activities. This issue may lead to Remote Code Execution (RCE). This issue has been patched in version 12.7.1.
Which versions are affected by CVE-2022-39377?
It affects 3 products.
Linux distribution packages (9)
sysstat AlmaLinux:8 | All versions | 11.7.3-9.el8 |
sysstat AlmaLinux:9 | All versions | 12.5.4-5.el9 |
sysstat Red Hat:enterprise_linux:8::appstream | All versions | 0:11.7.3-9.el8 |
sysstat-debuginfo Red Hat:enterprise_linux:8::appstream | All versions | 0:11.7.3-9.el8 |
sysstat-debugsource Red Hat:enterprise_linux:8::appstream | All versions | 0:11.7.3-9.el8 |
sysstat Red Hat:enterprise_linux:9::appstream | All versions | 0:12.5.4-5.el9 |
sysstat-debuginfo Red Hat:enterprise_linux:9::appstream | All versions | 0:12.5.4-5.el9 |
sysstat-debugsource Red Hat:enterprise_linux:9::appstream | All versions | 0:12.5.4-5.el9 |
sysstat openSUSE:Tumbleweed | All versions | 12.6.1-2.1 |
Products include Debian Debian Linux, Fedoraproject Fedora, Sysstat Project Sysstat.
How do I fix CVE-2022-39377?
Upgrade to a fixed version.
Is CVE-2022-39377 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39377 exists.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALSA-2023:2234, ALSA-2023:2800, AZL-11450, CLSA-2023-1685023359, CLSA-2023-1685023815, CLSA-2023-1685023926 and 10 more.