CVE-2022-39379 Fluentd vulnerable to remote code execution due to insecure deserialization (in non-default configuration)

Low 3.1 Published Updated

Unauthenticated attackers can execute arbitrary code via crafted JSON payloads in Fluentd when a specific non-default environment variable is set.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-39379?

CVE-2022-39379 is a low-severity unsafe deserialization vulnerability in Fedoraproject Fedora, published on 2 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. A remote code execution (RCE) vulnerability in non-default configurations of Fluentd allows unauthenticated attackers to execute arbitrary code via specially crafted JSON payloads. Fluentd setups are only affected if the environment variable `FLUENT_OJ_OPTION_MODE` is explicitly set to `object`. Please note: The option FLUENT_OJ_OPTION_MODE was introduced in Fluentd version 1.13.2. Earlier versions of Fluentd are not affected by this vulnerability. This issue was patched in version 1.15.3. As a workaround do not use `FLUENT_OJ_OPTION_MODE=object`.

Weakness: CWE-502

Which versions are affected by CVE-2022-39379?

3 open source packages ship an affected version, including fluentd. It affects 2 products.

PackageAffectedFixed in
fluentd BitnamiFrom 1.13.21.15.3
fluentd RubyGemsFrom 1.13.21.15.3
fluentd RubyGemsFrom 1.13.21.15.3

Products include Fedoraproject Fedora, Fluentd Fluentd.

How do I fix CVE-2022-39379?

Upgrade fluentd to 1.15.3 or later.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2022-39379 being exploited?

There is no known exploitation of CVE-2022-39379 in the wild and no public exploit code.

All Fedoraproject Fedora vulnerabilities

Sources

Also known as AZL-11396, BIT-fluentd-2022-39379, GHSA-fppq-mj76-fpj2, OESA-2025-2320, OESA-2025-2321.

Is CVE-2022-39379 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free