{"answers":{"affected":"3 open source packages ship an affected version, including fluentd. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-39379 in the wild and no public exploit code.","fix":"Upgrade fluentd to 1.15.3 or later.","what":"CVE-2022-39379 is a low-severity unsafe deserialization vulnerability in Fedoraproject Fedora, published on 2 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-39379 and fix it if it is affected.\n\nWhat it is: CVE-2022-39379 is a low-severity unsafe deserialization vulnerability in Fedoraproject Fedora, published on 2 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-39379 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fluentd (Bitnami): affected from 1.13.2; fixed in 1.15.3\n- fluentd (RubyGems): affected from 1.13.2; fixed in 1.15.3\n- fluentd (RubyGems): affected from 1.13.2; fixed in 1.15.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-39379/ (Markdown: https://insights.sbomify.com/CVE-2022-39379/index.md)","id":"CVE-2022-39379","markdown":"https://insights.sbomify.com/CVE-2022-39379/index.md","name":"CVE-2022-39379","record":{"aliases":["AZL-11396","BIT-fluentd-2022-39379","GHSA-fppq-mj76-fpj2","OESA-2025-2320","OESA-2025-2321"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Fluentd log collector","requires_auth":"low_privilege","summary":"Unauthenticated attackers can execute arbitrary code via crafted JSON payloads in Fluentd when a specific non-default environment variable is set.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"fluentd","vendor":"fluentd"}],"cvss":{"score":3.1,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. A remote code execution (RCE) vulnerability in non-default configurations of Fluentd allows unauthenticated attackers to execute arbitrary code via specially crafted JSON payloads. Fluentd setups are only affected if the environment variable `FLUENT_OJ_OPTION_MODE` is explicitly set to `object`. Please note: The option FLUENT_OJ_OPTION_MODE was introduced in Fluentd version 1.13.2. Earlier versions of Fluentd are not affected by this vulnerability. This issue was patched in version 1.15.3. As a workaround do not use `FLUENT_OJ_OPTION_MODE=object`.","ecosystems":["Bitnami","RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Fluentd vulnerable to remote code execution due to insecure deserialization (in non-default configuration)","id":"CVE-2022-39379","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"deserialization","year":"2022"},"n_packages":3,"n_references":3,"next":{"headline":"wire-webapp contains Improper Handling of Exceptional Conditions leading to a DoS via Markdown Rendering","id":"CVE-2022-39380"},"packages":[{"ecosystem":"Bitnami","fixed":["1.15.3"],"introduced":["1.13.2"],"last_affected":[],"package":"fluentd","purl":"pkg:bitnami/fluentd","source":"BIT-fluentd-2022-39379"},{"ecosystem":"RubyGems","fixed":["1.15.3"],"introduced":["1.13.2"],"last_affected":[],"package":"fluentd","purl":null,"source":"GHSA-fppq-mj76-fpj2"},{"ecosystem":"RubyGems","fixed":["1.15.3"],"introduced":["1.13.2"],"last_affected":[],"package":"fluentd","purl":"pkg:gem/fluentd","source":"GHSA-fppq-mj76-fpj2"}],"prev":{"headline":"Displaying user badges can leak topic titles to users that have no access to the topic","id":"CVE-2022-39378"},"products":["fluentd"],"published":"2022-11-02","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["fluent"]},"summary":"Unauthenticated attackers can execute arbitrary code via crafted JSON payloads in Fluentd when a specific non-default environment variable is set.","url":"https://insights.sbomify.com/CVE-2022-39379/"}