# CVE-2022-39379: Fluentd vulnerable to remote code execution due to insecure deserialization (in non-default configuration)

> Unauthenticated attackers can execute arbitrary code via crafted JSON payloads in Fluentd when a specific non-default environment variable is set.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Nov 2022
- **Updated:** 23 Apr 2025
- **Also known as:** AZL-11396, BIT-fluentd-2022-39379, GHSA-fppq-mj76-fpj2, OESA-2025-2320, OESA-2025-2321

## What is CVE-2022-39379?

CVE-2022-39379 is a low-severity unsafe deserialization vulnerability in Fedoraproject Fedora, published on 2 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. A remote code execution (RCE) vulnerability in non-default configurations of Fluentd allows unauthenticated attackers to execute arbitrary code via specially crafted JSON payloads. Fluentd setups are only affected if the environment variable `FLUENT_OJ_OPTION_MODE` is explicitly set to `object`. Please note: The option FLUENT_OJ_OPTION_MODE was introduced in Fluentd version 1.13.2. Earlier versions of Fluentd are not affected by this vulnerability. This issue was patched in version 1.15.3. As a workaround do not use `FLUENT_OJ_OPTION_MODE=object`.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2022-39379?

3 open source packages ship an affected version, including fluentd. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fluentd` | Bitnami | From 1.13.2 | 1.15.3 |
| `fluentd` | RubyGems | From 1.13.2 | 1.15.3 |
| `fluentd` | RubyGems | From 1.13.2 | 1.15.3 |

Products: Fedoraproject Fedora, Fluentd Fluentd.

## How do I fix CVE-2022-39379?

Upgrade fluentd to 1.15.3 or later.

## Is CVE-2022-39379 being exploited?

There is no known exploitation of CVE-2022-39379 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39379 and fix it if it is affected.

What it is: CVE-2022-39379 is a low-severity unsafe deserialization vulnerability in Fedoraproject Fedora, published on 2 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39379 in the wild and no public exploit code.

Affected packages and fixed versions:
- fluentd (Bitnami): affected from 1.13.2; fixed in 1.15.3
- fluentd (RubyGems): affected from 1.13.2; fixed in 1.15.3
- fluentd (RubyGems): affected from 1.13.2; fixed in 1.15.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39379/ (Markdown: https://insights.sbomify.com/CVE-2022-39379/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39379
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39379
- OSV: https://osv.dev/vulnerability/CVE-2022-39379

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39379/
Summaries are generated and may contain mistakes; the official description above is the record.
