# CVE-2022-39380: wire-webapp contains Improper Handling of Exceptional Conditions leading to a DoS via Markdown Rendering

> Attackers can cause a denial of service in Wire web-app by sending specific Markdown messages that crash the chat history rendering.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 Jan 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-v5mf-358q-w7m4

## What is CVE-2022-39380?

CVE-2022-39380 is a medium-severity denial of service vulnerability in wireapp wire-webapp, published on 27 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Wire web-app is part of Wire communications. Versions prior to 2022-11-02 are subject to Improper Handling of Exceptional Conditions. In the wire-webapp, certain combinations of Markdown formatting can trigger an unhandled error in the conversion to HTML representation. The error makes it impossible to display the affected chat history, other conversations are not affected. The issue has been fixed in version 2022-11-02 and is already deployed on all Wire managed services. On-premise instances of wire-webapp need to be updated to docker tag 2022-11-02-production.0-v0.31.9-0-337e400 or wire-server 2022-11-03 (chart/4.26.0), so that their applications are no longer affected. As a workaround, you may use an iOS or Android client and delete the corresponding message from the history OR write 30 or more messages into the affected conversation to prevent the client from further rendering of the corresponding message. When attempting to retrieve messages from the conversation history, the error will continue to occur once the malformed message is part of the result.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2022-39380?

It affects 1 product.


Products: Wire Wire-Webapp.

## How do I fix CVE-2022-39380?

No fix has been published for CVE-2022-39380 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-39380 being exploited?

There is no known exploitation of CVE-2022-39380 in the wild and no public exploit code.

## Other vulnerabilities in wireapp wire-webapp

- [CVE-2022-29168](https://insights.sbomify.com/CVE-2022-29168/): Cross Site Scripting in Wire Messages (critical 9.6)
- [CVE-2022-24799](https://insights.sbomify.com/CVE-2022-24799/): Cross Site Scripting in Wire Webapp (critical 9.6)
- [CVE-2021-32683](https://insights.sbomify.com/CVE-2021-32683/): XSS through createObjectURL (high 8.8)
- [CVE-2021-21400](https://insights.sbomify.com/CVE-2021-21400/): Entering code in App Lock modal sends input to conversation (high 7.1)
- [CVE-2025-48066](https://insights.sbomify.com/CVE-2025-48066/): wire-webapp has no database deletion on client logout (medium 6.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39380 and fix it if it is affected.

What it is: CVE-2022-39380 is a medium-severity denial of service vulnerability in wireapp wire-webapp, published on 27 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39380 in the wild and no public exploit code.

Affected product: wireapp wire-webapp. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39380/ (Markdown: https://insights.sbomify.com/CVE-2022-39380/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39380
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39380
- OSV: https://osv.dev/vulnerability/CVE-2022-39380

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39380/
Summaries are generated and may contain mistakes; the official description above is the record.
